Limitar la duracion en segundos del voicemail

Discussion in 'Elastix 2.x' started by AlanDaniel, Sep 8, 2010.

  1. AlanDaniel

    Joined:
    Mar 16, 2010
    Messages:
    47
    Likes Received:
    0
    Hola que tal, saben eh tratado de limitar el tiempo de grabado del voicemail pero no me ah funcionado.

    eh usado la opción maxmessage=30 pero nada.

    espero que alguien pueda ayudarme para ver como se logra esto.


    saludos
     
  2. pinazo

    Joined:
    Aug 12, 2010
    Messages:
    19
    Likes Received:
    0
    Esa opción es para el Asterisk viejo.
    Para el nuevo mira un poco más abajo dentro del mismo archivo, la opción es maxsecs
     
  3. AlanDaniel

    Joined:
    Mar 16, 2010
    Messages:
    47
    Likes Received:
    0
    sabes acabo de poner maxsecs=30 y nada el voicemail se va a 2 minutos no se por que, esto en la version 1.6
     
  4. pinazo

    Joined:
    Aug 12, 2010
    Messages:
    19
    Likes Received:
    0
    Lo estás poniendo dentro de PBX, sección Extensions, dentro de Voicemail & Directory, en VM Options?
     
  5. AlanDaniel

    Joined:
    Mar 16, 2010
    Messages:
    47
    Likes Received:
    0
    exactamente eso hago, o lo tengo que poner en otro lado?
     
  6. pinazo

    Joined:
    Aug 12, 2010
    Messages:
    19
    Likes Received:
    0
    Cada vez que hacés los cambios estás reiniciando Asterisk antes de probarlos?
    Estás usando Elastix 2.0?
     
  7. AlanDaniel

    Joined:
    Mar 16, 2010
    Messages:
    47
    Likes Received:
    0
    fijate que esta vez con minsecs no reinicio asterisk seria bueno probarlo, bastaria con reiniciar solo asterisk me imagino o recomiendas todo el sistema?
     
  8. pinazo

    Joined:
    Aug 12, 2010
    Messages:
    19
    Likes Received:
    0
    Debería bastar con Asterisk solamente
     
  9. AlanDaniel

    Joined:
    Mar 16, 2010
    Messages:
    47
    Likes Received:
    0
    Re: Re:Limitar la duracion en segundos del voicemail

    no se detiene a los 30 seg, solo se detiene cuando hay un silencio de 5 seg
    [general]
    #include vm_general.inc
    #include vm_email.inc
    [default]
    306 => 1234,Compras,,,maxsecs=30|attach=no|saycid=no|envelope=no|delete=no

    ASI ESTA MI ARCHIVO VOICEMAIL
     
  10. l.chavez.08

    Joined:
    Feb 11, 2010
    Messages:
    3
    Likes Received:
    0
    Hola Alan

    Para Limitar el numero de mensajes en Elastix lo puedes hacer la siguiente forma:

    Escribir "maxmsg= numero maximo de mensajes" en la opcion Extension-->Voicemail & Directory-->VM Options

    Otra forma es:

    En el archivo voicemail.conf colocar la siguiente linea:

    306 => 1234,Compras,,,maxmsg=3|attach=no|saycid=no|envelope=no|delete=no

    Otra forma para delimitar todas las extensiones con Voicemail es:

    En el archivo voicemail.conf debajo del contexto [general] colocar las siguientes lineas:


    [general]
    #include vm_general.inc
    #include vm_email.inc
    maxmsg=10
    skipms=3000 ;(opcional) esto tal vez sea lo que andas buscando al delimitar el tiempo
    maxsilence=10

    Espero sea de utilidad,

    Saludos
     

Share This Page