IVR Volume txgain rxgain no luck, even active?

Discussion in 'General' started by agidi, Aug 13, 2008.

  1. agidi

    Joined:
    Jan 13, 2008
    Messages:
    152
    Likes Received:
    0
    Hi guys

    I recorded some nice IVR prompts on my PC, when I transfer them over to my elastix box., They sound really low in volume.:(

    I searched and some posts say to increase the rxgain and txgain on zap files. I've tried and had no luck. Then again
    Elastix has a bunch of modified files.
    zapata-channels.conf
    zapata-channels.conf.bak
    zapata.conf :blink:
    zapata.conf.replaced_for_elastix :blink:
    zapata.conf.template
    zapata_additional.conf

    Which ones are the "live" ones?

    all ideas pointers and suggestions are welcomed.

    thanks
     
  2. snowspeeder

    Joined:
    Aug 13, 2008
    Messages:
    20
    Likes Received:
    0
    The rx and tx gains would only raise the volume of any digital or analog cards "such as T1 or fxs/o" you have in your pbx. Can you hear callers/ees at an optimum level? I would suggest rerecording your greetings. Perhaps record from a phone for a test to see if it truly is elastix passing on low audio.

    I would try recording at 8khz and saving as a mono wav file. Then upload to freepbx.

    BTW. rx and tx can be changed from
    /etc/asterisk/zapata.conf

    they look like this

    rxgain=-4.0
    txgain=-4.0

    hope this helps.
     
  3. agidi

    Joined:
    Jan 13, 2008
    Messages:
    152
    Likes Received:
    0
    Hi
    I tried 8k 16bit WAV, 44k 43bit mp3s, anything I upload sounds low. If I record it from a phone, it sounds nice and loud.

    my rx tx gains are default 0.0. I tried changing them, but hear no difference.

    thanks
     
  4. snowspeeder

    Joined:
    Aug 13, 2008
    Messages:
    20
    Likes Received:
    0
    Is freepbx set to convert the file upon upload? If so, disable it.
     
  5. snowspeeder

    Joined:
    Aug 13, 2008
    Messages:
    20
    Likes Received:
    0
    also note, that after you change the rx tx gains you either have to amportal restart

    or

    asterisk -rvv

    reload chan_zap.so

    before the settings will take effect.
     

Share This Page