IVR not working correctly?

Discussion in 'General' started by phonehell, Jun 11, 2009.

  1. phonehell

    Joined:
    Jun 4, 2009
    Messages:
    3
    Likes Received:
    0
    Alrighty...after a month of playing with this and having numerous people tell me to fix my phones here I am asking for help. I have Elastix 1.3.2 installed and I am having a pretty difficult time setting it up. The way I want it to ring is my extention first, then if no answer the IVR. I also have time conditions set for the IVR to answeer directly between 6pm-10am weekdays and all days weekends. The problem I am having is that no matter what was I set it up either it rings my extension repeatedly or there is no ringing and the IVR message cannot be heard. The menu options for the IVR work though as I tired them all so I know that somehow it is ringing into the IVR and I get an email setn for a new voicemail. Is this a known issue or is my configuration off? Any help would be appreciated.

    Another issue I am having is with inbound calls. When I pick up the phone the person on the other end doesn't hear me but I can hear them. Outbound calling works so I'm not sure what the beef is. I have all VOIP trunks and Spa942 phones. Any help would be appreciated. Thanks!
     
  2. phonehell

    Joined:
    Jun 4, 2009
    Messages:
    3
    Likes Received:
    0
    Just to add a bit of info here....when I dial the phone number from my phone it plays the IVR recording and I'm testing it with a cell phone. Is it possible there is something going on with the codec?? I did try it from a regular landline and got no recording either...
     
  3. phonehell

    Joined:
    Jun 4, 2009
    Messages:
    3
    Likes Received:
    0
    Another tidbit of info... I noticed on all my trunks the incoming settings are blank..after a bit more reading would this be the cause? As in the fact Elastix doesn't know what codec to send out the recording in?
     
  4. davidh

    Joined:
    May 13, 2008
    Messages:
    20
    Likes Received:
    0
    here u go hope this helps;)

    I want it to ring is my extention first
    --(setup any did in incoming routes to go to your extension)
    , then if no answer
    --(call forwarding on your extesnion in extension setup under pbx, select ring time before forwarding the call and the at the botom select the ivr you have created)
    the IVR
    --(must created first before it would show up in the call forwarding section under your extension)

    . I also have time conditions set for the IVR to answeer directly between 6pm-10am weekdays and all days weekends. The problem I am having is that no matter what was I set it up either it rings my extension repeatedly or there is no ringing and the IVR message cannot be heard. The menu options for the IVR work though as I tired them all so I know that somehow it is ringing into the IVR and I get an email setn for a new voicemail.
    --(I think you just need to read up the ivr always works great, with no hassles, i think you need to just read up some more about routing in elastix)

    Is this a known issue or is my configuration off? Any help would be appreciated.
     

Share This Page