IVR , DISA Bug Elastix 1.6

Discussion in 'General' started by Guiloui0875, Jan 12, 2010.

  1. Guiloui0875

    Joined:
    Sep 8, 2008
    Messages:
    2
    Likes Received:
    0
    Guys

    I'm not very sure if this is a freepbx or asterisk issue since both are trunk versions and this is a fresh install of 1.6. I'll be posting this bug report for both freepbx and asterisk.

    All instances of digit timeout seem to have negative time even though a positive value was set:

    IVR
    -- Executing [s@ivr-4:5] GotoIf("SIP/xx.xx.xx.xx-083c0e40", "1?begin") in new stack
    -- Goto (ivr-4,s,8)
    -- Executing [s@ivr-4:8] Set("SIP/xx.xx.xx.xx-083c0e40", "TIMEOUT(digit)=3") in new stack
    -- Digit timeout set to -2144.483
    -- Executing [s@ivr-4:9] Set("SIP/xx.xx.xx.xx-083c0e40", "TIMEOUT(response)=10") in new stack
    -- Response timeout set to 10.000


    Similarly for DISA
    -- Executing [1@ivr-3:3] Goto("SIP/xx.xx.xx.xx-083c0e40", "disa,1,1") in new stack
    -- Goto (disa,1,1)
    -- Executing [1@disa:1] Set("SIP/xx.xx.xx.xx-083c0e40", "TIMEOUT(digit)=5") in new stack
    -- Digit timeout set to -2142.483
    -- Executing [1@disa:2] Set("SIP/xx.xx.xx.xx-083c0e40", "TIMEOUT(response)=10") in new stack
    -- Response timeout set to 10.000

    Notice that response timeout still works as normal and that the timeout seems to be overflowing as the negative values seem to change proportionally to the value of timeout specified.

    Bottom line nothing works with IVR from when dialing from the outside. it works if dialing local extensions. I tried to use fwding rule from the out side but I get the same results. Any idea? anyone having the same issue with 1.6 version when it comes to IVR or DISA .....Thanks

    https://issues.asterisk.org/view.php?id=12801
     

Share This Page