ISDN card not detected

kalderista

Joined
Oct 21, 2008
Messages
179
Likes
0
Points
0
#1
Hi all!

I´ve elastix 1.3-2 allready installed with one analog PCI card and one ISDN card. Both are Digium cards.

The problem I have is that the ISDN card is not detected. I go to hardwre detection and it doesn´t apear anywhere.

Am I doing it in the right way?

Tanx!
 

Bob

Joined
Nov 4, 2007
Messages
2,400
Likes
1
Points
36
#2
kalderista,

Can we go back to basics first.

1) Can you provide the model number of the cards your are using (e.g. TE122 and TDM410).
2) if you issue the command at the Linux prompt, lspci can you see both cards listed??
3) If you install just the ISDN card, is it detected?

regards
Bob
 

kalderista

Joined
Oct 21, 2008
Messages
179
Likes
0
Points
0
#3
OK,...

As I can read in the card, I'm not sure if it´s really a digium card.

This is the information in the PCI card:

HFC-S PCI a
2BDS0 ISDN

UMEC UT20795-00TS

BIPAC PCI

PW2BIPPCI30

Is there any valid information?

Thanx again.
 

jgutierrez

Joined
Feb 28, 2008
Messages
5,737
Likes
0
Points
0
#4
if you run:
misdn-init scan

what do you get?
 

kalderista

Joined
Oct 21, 2008
Messages
179
Likes
0
Points
0
#5
I get this:

[root@elastix ~]# misdn-init scan
[OK] found the following devices:
card=1,hfcpci
[ii] run "/usr/sbin/misdn-init config" to store this information to /etc/misdn-init.conf
[root@elastix ~]#
 

jgutierrez

Joined
Feb 28, 2008
Messages
5,737
Likes
0
Points
0
#6
ok, follow these steps:

1. misdn-init config
2. edit /etc/asterisk/misdn.conf
find the following line:
misdn_init=/etc/misdn-init.conf
there you must change it to the correct name of misdn file that you will find on /etc, if I'm not mistaken, you will
find on /etc another name (I think it had some capital letters)
3. Comment all these lines on the same configuration file:
Code:
[intern]
; define your ports, e.g. 1,2 (depends on mISDN-driver loading order) 
ports=1,2
; context where to go to when incoming Call on one of the above ports
context=Intern

[internPP]
;
; adding the postfix 'ptp' to a port number is obsolete now, chan_misdn
; parses /etc/misdn-init.conf and sets the ptp mode to the corresponding
; configs. For backwards compatibility you can still set ptp here.
;
ports=3

[first_extern]
; again port defs
ports=4
; again a context for incoming calls
context=Extern1
; msns for te ports, listen on those numbers on the above ports, and 
; indicate the incoming calls to asterisk
; here you can give a comma separated list or simply an '*' for 
; any msn. 
msns=*

; here an example with given msns
[second_extern]
ports=5
context=Extern2
callerid=15
msns=102,144,101,104
4. Write down a simple context at the end of the file, something like this:
Code:
[misdnchannels]
ports=1,2
msns=*
context=from-pstn
echocancel=yes
in the port variable, you should enter the number os ports that you have

On the web interface you may set the incoming routes based on DIDs, or set anyCID/anyDID to route all incoming calls to a specific destination that you choose

5. create a custom trunk on the web interface
define the following dial string:
mISDN/g:misdnchannels/$OUTNUM$
6. misdn-init start

on the cli you may use this command to see the status of your channels:
asterisk -r
misdn show stacks
 

kalderista

Joined
Oct 21, 2008
Messages
179
Likes
0
Points
0
#7
where should I write the mISDN/g:misdnchannels/$OUTNUM$ dial string? I´m trying to write it crating a new SIP trunk ut I don´t find any option to set this.

...thank you anyway
 

jgutierrez

Joined
Feb 28, 2008
Messages
5,737
Likes
0
Points
0
#8
you should go to:
PBX -> Trunks -> Add Custom Trunk

In the outgoing settings, you will find the Custom Dial String field

You may leave the other fields in blank
 

kalderista

Joined
Oct 21, 2008
Messages
179
Likes
0
Points
0
#9
Solved!!!!!

Thanks a lot, gracias, mil gracias....

Saludos.:woohoo:
 

jgutierrez

Joined
Feb 28, 2008
Messages
5,737
Likes
0
Points
0
#10
Excellent news!!!!
 

grantapple

Joined
Nov 21, 2011
Messages
13
Likes
0
Points
0
#11
Morning,

I have been struggling to receive incoming calls using my BEROFIX 1600 PCI card.

When I installed it into the machine it picked up as a network card. However when I follow the book, it instructs me to navigate to "HARDWARE DETECTION" at which time it does not find anything. We are currently running 3CX with that card and it all seems to be working 100%. I never set up the 3cx but I know there must be something I am doing wrong in elastix. Beronet advised me that this card will work on a linux platform and does not require any drivers.


Could anyone please help me?
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,886
Members
17,564
Latest member
Mai Tuyen
Top