is this config correct

Discussion in 'General' started by telecomtechnician, Aug 20, 2010.

  1. telecomtechnician

    Joined:
    Jan 8, 2008
    Messages:
    422
    Likes Received:
    0
    Hi elastix community

    I want your opinion about the following configuration, is it good? is it bad? will it work in elastix?

    I can tell you that in my elastix server is not working. My sip trunks do not register.

    Waiting for your comments

    David Medina


    ; SIP Configuration for Asterisk
    ;
    [general]
    port = 5060 ; Port to bind to
    bindaddr = 0.0.0.0 ; Address to bind to
    maxexpirey=60 ; Max length of incoming registration we allow
    defaultexpirey=180 ; Default length of incoming/outoing registration

    disallow=all ; Disallow all codecs
    allow=g729

    dtmfmode=rfc2833


    register => 771XXXXXXX:123456789:771XXXXXXX@ssc01.comvoz.com/771XXXXXXX

    [ssc01.comvoz.com]
    type=friend
    disallow=all
    allow=g729
    host=ssc01.comvoz.com
    username=771XXXXXXX
    fromuser=771XXXXXXX
    secret=123456789
    context=sip-in
    canreinvite=no
    nat=yes
    qualify=yes
    insecure=very
     
  2. telecomtechnician

    Joined:
    Jan 8, 2008
    Messages:
    422
    Likes Received:
    0
    Re:is this config correct (SOLVED)

    This file is fine. The real problem was solved in the following way:

    My router´s state tables had to be flushed. Once it was done, (resetting the router to default), the trunks registered with the sip provider with no problem.

    Last night I got into the elastix IRC chat, and somebody gave me the solution. Definetely, network acknowledge is very important.

    I have to be aware of this, because I turn off all my telecom equipment at night. Or maybe I might not turn off the router and internet modem.

    Thanks everybody

    David Medina
     

Share This Page