Is it possible to get this asterisk patch in 1.4

Discussion in 'General' started by jandir, Dec 16, 2008.

  1. jandir

    Joined:
    Aug 24, 2008
    Messages:
    65
    Likes Received:
    0
    http://bugs.digium.com/view.php?id=13209

    It is screwing up my outgoing DTMF

    Thanks

    ~~~~~~~~~ Extract for forum search ~~~~~~~~~~~~~~~~~
    0013209: DTMF RFC2833 via SIP is not working

    Using provider bandwidth.com which support RFC2833. Configure outbound trunk to use dtmfmode=rfc2833 and we receive double digits on a different asterisk servers IVR. American Express IVR does not accept any digits (used main customer service line to test entering credit card number). Other IVR functions do not work.

    Changing to inband works but inband should not be required by bandwidth.com, they support rfc2833.

    Configuration is using SIP devices and SIP trunks only. A search in issue tracker found similar problems in January of 2008 but no currently open issues.

    .
    .
    .

    The attempt was to send DTMF digits 12345678#, what was sent was 1111112333333444444566666678###
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
     
  2. Tgarius

    Joined:
    Jan 19, 2009
    Messages:
    2
    Likes Received:
    0
    Did you ever get this figured out, I've had to go to inband.. I also have bandwidth.com
     
  3. jandir

    Joined:
    Aug 24, 2008
    Messages:
    65
    Likes Received:
    0
    Nope. I had to change to inband too. Waiting to hear or to try whether this issue will be fixed in Elastix 1.4 or not. I have not tried out the Beta or RC 1.4 releases.

    I had posted about this in the 1.4 announcement thread but have not got a definitive response about the fix being in 1.4 or not.

    I am on viatalk.
     
  4. Tgarius

    Joined:
    Jan 19, 2009
    Messages:
    2
    Likes Received:
    0
    It looks like they added the patch on Dec, 9th to the Asterisk fix's so whatever version came out after that date should have the patch. I see they are on 1.4.22.1 so hopefully they will include that with the 1.4 version.
     

Share This Page