Internal caller id issues

Discussion in 'General' started by markrmcs, Oct 17, 2008.

  1. markrmcs

    Joined:
    May 8, 2008
    Messages:
    3
    Likes Received:
    0
    I have elastix 1.3 running on a supermicro server with a Digium TDM2400 card with 2 4-port FXS modules, and 1 4-port FXO module.

    The card is recognized and configured fine by elastix. All 8 FXS channels work and calls can be placed between the analog phones and all other phones, both SIP and analog.

    My issue is the incorrect caller id passed by the analog phones.

    My zapata.conf file includes the following lines at the end:


    #include zapata_additional.conf
    #include zapata-channels.conf




    My zapata_additional.conf contains:

    =======================================

    ;--------------------------------------------------------------------------------;
    ; Do NOT edit this file as it is auto-generated by FreePBX. All modifications to ;
    ; this file must be done via the web gui. There are alternative files to make ;
    ; custom modifications, details at: http://freepbx.org/configuration_files ;
    ;--------------------------------------------------------------------------------;
    ;

    ;;;;;;[111]
    signalling=fxo_ks
    pickupgroup=
    mailbox=111@device
    immediate=no
    echotraining=800
    echocancelwhenbridged=no
    echocancel=yes
    context=from-internal
    callprogress=no
    callgroup=
    callerid=device <111>
    busydetect=no
    busycount=7
    accountcode=
    channel=>1

    ;;;;;;[112]
    signalling=fxo_ks
    pickupgroup=
    mailbox=112@device
    immediate=no
    echotraining=800
    echocancelwhenbridged=no
    echocancel=yes
    context=from-internal
    callprogress=no
    callgroup=
    callerid=device <112>
    busydetect=no
    busycount=7
    accountcode=
    channel=>2
    ...etc...


    =======================================



    and zapata-channels.conf contains:


    =======================================

    ; Autogenerated by /usr/local/sbin/genzaptelconf -- do not hand edit
    ; Zaptel Channels Configurations (zapata.conf)
    ;
    ; This is not intended to be a complete zapata.conf. Rather, it is intended
    ; to be #include-d by /etc/zapata.conf that will include the global settings
    ;

    ; Span 1: WCTDM/0 "Wildcard TDM2400P Board 1" (MASTER)
    ;;; line="1 WCTDM/0/0"
    signalling=fxo_ks
    callerid="Channel 1" <6001>
    mailbox=6001
    group=5
    context=from-internal
    channel => 1
    callerid=
    mailbox=
    group=
    context=default

    ;;; line="2 WCTDM/0/1"
    signalling=fxo_ks
    callerid="Channel 2" <6002>
    mailbox=6002
    group=5
    context=from-internal
    channel => 2
    callerid=
    mailbox=
    group=
    context=default
    ...etc...


    =======================================


    zapata_additional.conf contains the correct extension information (111, 112, etc) The caller ID that is passed is the information from zapata-channels.conf (6001, 6002, etc). If I comment out the zapata-channels.conf in zapata.conf and restart amportal then the correct caller ID is passed (111, 112, etc).

    Do both files need to be included or just zapata_additional.conf? Or should I hand edit zapata-channels.conf even though the comments at the beginning explicitly say not to do this? Any feedback would be appreciated.


    Thanks,

    Mark
     

Share This Page