Installing exim MTA in elastix server ?

Discussion in 'General' started by gypsygoks, Apr 20, 2009.

  1. gypsygoks

    Joined:
    Apr 13, 2009
    Messages:
    10
    Likes Received:
    0
    Hi,

    I have succesfully installed Elastix in my server ( Xen VPS). The MTA that got installed is Sendmail. I have a few accounts hosted in a shared cpanel linux server which uses Exim as MTA. I want to transfer/migrate mail alone of a few accounts to server where elastix is installed.
    In that case, can i install exim in the server where elastix is installed?. Will this affect elasix installation and its email related functions afterwards. Please have a look and advice on this.

    Thanks in advance.
    Regards,
    Gokul
     
  2. rafael

    Joined:
    May 14, 2007
    Messages:
    1,454
    Likes Received:
    1
    Everything should work fine, excpet the mail module from elastix web interface. In fact Elastix uses postfix, not sendmail, so by changing sendmail to exim would be the same thing. I haven't use exim, but if it can be installed in CentOS you should be just fine.

    Regards,

    rafael
     
  3. gypsygoks

    Joined:
    Apr 13, 2009
    Messages:
    10
    Likes Received:
    0
    Hello Rafael,

    Thanks for the reply. Yes, the primary MTA in elastix server is postfix. Inorder to transfer the mails alone for the accounts hosted in cpanel server that houses exim MTA, shall i install exim in elastix server. Then , proceed with the transfer.

    Thanks and Regards,
    Gokul
     
  4. gypsygoks

    Joined:
    Apr 13, 2009
    Messages:
    10
    Likes Received:
    0
    Hello,

    I am trying to install exim to the elastix server having centos using yum.

    However yum install could not proceed further due to the error--
    ----------------------------------
    file:///mnt/elastix-cd/repodata/repomd.xml: [Errno 5] OSError: [Errno 2] No such file or directory: '/mnt/elastix-cd/repodata/repomd.xml'
    Trying other mirror.
    Error: Cannot retrieve repository metadata (repomd.xml) for repository: elastix-CD. Please verify its path and try again
    ------------------------------------

    Please advice. Thanks

    Gokul
     
  5. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    Have you changed anything in /etc/yum.repos.d ?
    It is trying to use the elastix-cd as repository.
    This is strange, it should use online repositories.
    What elastix version are you using?
    How did you install it to the Xen VPS?
     

Share This Page