Instalacion de OpenVox A400P en elastix 2.0

Discussion in 'Elastix 2.x' started by Federico Schmale, Oct 1, 2010.

  1. Federico Schmale

    Joined:
    Oct 1, 2010
    Messages:
    3
    Likes Received:
    0
    Hola,
    estoy instalando una placa OpenVox A400P (1FXS, 1FXO)en Elastix 2.0.2 que ya viene con drivers dahdi.
    Desde el detector de hardware no me detecta nada, usando cualquiera de las opciones, ISDN, sangoma.. nada de nada.
    Desde linea de comandos corro el lspci y veo que tengo conectado un "communication controller: Tiger Jet Network Inc. Tiger3XX Modem/ISDN interface"
    Que me puedo estar salteando o donde puede estar el problema.
    Muchas Gracias,

    Fede
     
  2. Federico Schmale

    Joined:
    Oct 1, 2010
    Messages:
    3
    Likes Received:
    0
    Federico Schmale escribió:
    Salida desde linea de comandos:

    [root@Elastix sbin]# hardware_detector
    HWDETECT: Starting card detection...
    HWDETECT: Stopping Asterisk...
    HWDETECT: Unloading dahdi modules...
    HWDETECT: Stopping and deactivating mISDN service...
    HWDETECT: Probing for dahdi modules...
    HWDETECT: Generating configuration for detected dahdi cards...
    HWDETECT: Restarting dahdi service...
    HWDETECT: Restarting asterisk service...
    HWDETECT: End of card detection.

    [root@Elastix sbin]# dahdi_genconf
    Empty configuration -- no spans
    Empty configuration -- no spans


    cat /etc/dahdi/system.conf
    # Autogenerated by /usr/sbin/dahdi_genconf on Fri Oct 1 14:14:23 2010
    # If you edit this file and execute /usr/sbin/dahdi_genconf again,
    # your manual changes will be LOST.
    # Dahdi Configuration File
    #
    # This file is parsed by the Dahdi Configurator, dahdi_cfg
    #
    # Global data

    loadzone = us
    defaultzone = us

    [root@Elastix sbin]# dahdi_hardware
    pci:0000:04:01.0 wctdm- e159:0001 Wildcard TDM400P REV E/F
     
  3. Federico Schmale

    Joined:
    Oct 1, 2010
    Messages:
    3
    Likes Received:
    0
    Federico Schmale escribió:
    Salida desde linea de comandos:

    [root@Elastix sbin]# hardware_detector
    HWDETECT: Starting card detection...
    HWDETECT: Stopping Asterisk...
    HWDETECT: Unloading dahdi modules...
    HWDETECT: Stopping and deactivating mISDN service...
    HWDETECT: Probing for dahdi modules...
    HWDETECT: Generating configuration for detected dahdi cards...
    HWDETECT: Restarting dahdi service...
    HWDETECT: Restarting asterisk service...
    HWDETECT: End of card detection.

    [root@Elastix sbin]# dahdi_genconf
    Empty configuration -- no spans
    Empty configuration -- no spans


    cat /etc/dahdi/system.conf
    # Autogenerated by /usr/sbin/dahdi_genconf on Fri Oct 1 14:14:23 2010
    # If you edit this file and execute /usr/sbin/dahdi_genconf again,
    # your manual changes will be LOST.
    # Dahdi Configuration File
    #
    # This file is parsed by the Dahdi Configurator, dahdi_cfg
    #
    # Global data

    loadzone = us
    defaultzone = us

    [root@Elastix sbin]# dahdi_hardware
    pci:0000:04:01.0 wctdm- e159:0001 Wildcard TDM400P REV E/F
     
  4. security

    Joined:
    May 14, 2007
    Messages:
    299
    Likes Received:
    0
    y bueno...quien sabe como se configuran estas openvox en la nueva version de elastix?????? :unsure: :unsure: :unsure: :unsure: :unsure:
     
  5. danieldoe

    Joined:
    Aug 29, 2010
    Messages:
    7
    Likes Received:
    0
    Yo tengo el mismo problema, unicamnte he logrado que las OPENVOX A400P funcionen en la version 1.6 y 1.6.2 de elastix, pero a partir de la 2 nada funciona, al parecer tiene que ver algo con DAHDI, yo he intentado bajando todo manualmente , comiplarlo e instalarlo pero tampoco da, alguien sabe como hacer funcionar estas tarjetas??
     
  6. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    Lo que haría es instalar 2.0 estable, hacer un yum update, y luego desde la interfaz web hacer un hardware detection, le das en advanced, y seleccionas que reemplace el chan_dahdi
     
  7. danieldoe

    Joined:
    Aug 29, 2010
    Messages:
    7
    Likes Received:
    0
    Bueno aqui esta la solucion a este problema, estaba algo complicaod de atinarle. Resulta efectivamente que por alguna extraña razon el Kernel de linux y el kmod-dahdi de dahdi no coinciden. Para verificar que este sea su caso tienen que hacer esto:

    Ejectuar este comando:

    rpm -qa | grep -i dahdi

    Les va a salir algo mas o menso como esto:

    dahdi-tools-doc-2.2.0-4_trixbox
    dahdi-tools-2.3.0-1_trixbox
    kmod-dahdi-linux-2.3.0.1-1_trixbox.2.6.18_164.11.1.el5
    dahdi-linux-2.3.0.1-1_trixbox
    asterisk16-dahdi-1.6.0.26-1_trixbox

    Pongan atencion a la linea que empieza con kmod-dahdi y la parte de _2.6.18_164.11.1.e15 que es la version del kernel para kmod.

    Luego ejecutan este comando para checar que kernel tienen:

    uname -a

    Les saldra algo parecido a esto:

    Linux trixbox1 2.6.18-164.11.1.el5xen #1 SMP Wed Jan 20 07:39:04 EST 2010 i686 i686 i386 GNU/Linux

    La cosa aqui es que el kmod-dahdi instalado, si corresponde a la version del kernel pero no tiene XEN o para otras personas PAP , por lo que hay que reinstalar el kmod-dahdi con el siguiente comando:

    yum install kmod-dahdi-linux-xen

    Para verificar que ya esta funcionando su tarjeta openvox a400p y dahdi, vuelvan a iniciar dahhdi con el siguietne comando:

    service restart dahdi

    Si todo esta en OK en ves de rojo, ya estan del otro lado. Espero que alguien mas le sirva esta solucion ya que yo llevaba mucho tiempo buscandola, al parecer solo sucede con hardware en especifico, en mi caso por no tener la parte de XEN, es por eso que si reinstalas elastix en hardware diferente o inclusive un puerto pci diferente, si funciona.

    Solucion por Daniel Rodrigo Aguilera Trigos
    Director General Drattek
    www.drattek.com
     
  8. danieldoe

    Joined:
    Aug 29, 2010
    Messages:
    7
    Likes Received:
    0
    Otra opcion menos compleja es ejecutar este comando:

    yum install kernel*

    En caso de que no les sirve el yum install kmod ...
     
  9. mm.alpha2k

    Joined:
    Jun 19, 2010
    Messages:
    165
    Likes Received:
    0
    Me paso algo similiar, pero con placas openvox.
    Cuando reiniciaba el server no me levantaba la placa, luego probe apagarla por completo y volverla a prender, y recien ahi me funciono.

    Nose si te servira esto que me paso.
    saludos.
     
  10. danieldoe

    Joined:
    Aug 29, 2010
    Messages:
    7
    Likes Received:
    0
    con yum install kernel* , solucione lo de que no detectaba la tarjeta A400P, pero ahora cuando entro a la interface web de elastix, unicamente me aparece la pantalla del sistema y todo es inservible, elastix 2.0 realmente es muy malo, creo que va a ser imposible hacerlo funcionar, me recomendarian regresar a la version 1.6 o alguien sabe como solucionar el problema de la interfase web? ya he visto en algunos foros que tienen el problema similar pero nadie lo ha resuelto por completo.
     
  11. raulitozubi

    Joined:
    May 8, 2011
    Messages:
    2
    Likes Received:
    0
    Hola, sabéis si con la versión 2.0.3 ya funciona correctamente la tarjeta, es que estoy diciendo cual me compro. Muchas gracias.
     
  12. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    En particuklr no he tenido problema alguno con esa tarjeta en cualquier versión de elastix
     

Share This Page