Instalación Elastix en CentOS 5.3

Discussion in 'Elastix 2.x' started by jpagarcia, Jun 20, 2009.

  1. jpagarcia

    Joined:
    Jun 20, 2009
    Messages:
    17
    Likes Received:
    0
    Hola

    Estoy trabajando sobre Xen, instalé una máquina virtual con CentOS 5.3. Luego seguí todos los pasos que se indican en esta guía: http://www.elastix.org/index.php?option ... om_centos5

    Al parecer no me da error, pero cuando reinicio e intento entrar a mi url (http://miIp) no hay nada... No sé si es un problema de instalación o me falta hacer algo, ¿cómo verifico que se haya instalado Elastix?, ¿cómo verifico si Elastix está corriendo?

    Instalé Elastix-1.5.2-stable-x86_64-bin-31mar2009.iso y en CentOS 5.3 tengo el kernel kernel-2.6.18-92.1.22.el5 -
    kernel-2.6.18-128.1.14.el5

    Por favor, si alguien me puede ayudar, hace días que estoy trancado con este problema, al menos indicarme como ver si se instaló correctamente y si Elastix está corriendo (o como levantar Elastix en caso contrario)

    Gracias!!
    Juan Pablo
     
  2. jcastellanos

    Joined:
    Feb 10, 2009
    Messages:
    2,404
    Likes Received:
    0
    checa si el apache esta corriendo
     
  3. jpagarcia

    Joined:
    Jun 20, 2009
    Messages:
    17
    Likes Received:
    0
    jcastellanos, efectivamente apache no estaba levantado. Logré levantarlo, al entrar a MiIP veo la página de inicio de apache. Según la guía debería ver la de Elastix. ¿cómo puedo ver si elastix está corriendo? o cómo puedo ver si elastix está instalado?

    gracias!!!
     
  4. jcastellanos

    Joined:
    Feb 10, 2009
    Messages:
    2,404
    Likes Received:
    0
    bueno, realmente nunca lo he hecho asi, pero fijate en las direcciones creo var/www o algo asi, tendria que venir los php del elastix
    no tengo fresca la ubicacion (pero estoy casi seguro que es esa)y busca algo con respecto al elastix :), seguro lo encuentras.

    temgo una duda, por que no instalar el ISO de elastix? en lugar de montarlo en un centos???

    saludos
     
  5. jpagarcia

    Joined:
    Jun 20, 2009
    Messages:
    17
    Likes Received:
    0
    En realidad, en otra máquina virtual tenemos Elastix funcionando correctamente, lo instalamos desde el iso...
    Estuvimos leyendo que instalándolo de esta forma Elastix hace un manejo más eficiente de los recursos como la memoria.

    Lo que me sucede es que no veo los archivos .php de elastix por ningún lugar, sin embargo cuando ejecuto el yum -y install asterisk* elastix-* freeze fxload kernel-module-rhino* libmfcr2 lzop perl-HTML-TokeParser-Simple perl-WWW-Mechanize pone que instala todo correctamente. Adjunto la captura de pantalla

    Luego, cuando reinicio no veo nada de elastix en todo el disco duro, es más si hago un find -name "*.php", no hay nada...

    gracias!!
     
  6. jpagarcia

    Joined:
    Jun 20, 2009
    Messages:
    17
    Likes Received:
    0
    Adjunto nuevamente la imagen... [​IMG]
     
  7. jcastellanos

    Joined:
    Feb 10, 2009
    Messages:
    2,404
    Likes Received:
    0
    entiendo, esto es muy extraño, se ha de bajar en un temporal o algo asi, no hay nada en var/www????????????
     
  8. jpagarcia

    Joined:
    Jun 20, 2009
    Messages:
    17
    Likes Received:
    0
    en www hay las siguientes carpetas (ninguna de ellas tiene archivos php):
    cgi-bin
    error
    html (esta está vacía)
    icons
    manual
    usage

    además, si vuelvo a ejecutar yum -y install asterisk* elastix-* freeze fxload kernel-module-rhino* libmfcr2 lzop perl-HTML-TokeParser-Simple perl-WWW-Mechanize me pone el mismo mensaje, como que instaló 84 paquetes. Es decir, no reconoce nada instalado y así sigue... por ahi me falta hacer algo luego de ejecutar esto, es posible?

    gracias
     
  9. jpagarcia

    Joined:
    Jun 20, 2009
    Messages:
    17
    Likes Received:
    0
    Jorge, pregunto si no me falta algo después de hacer el yum -y install asterisk* elastix-* freeze fxload kernel-module-rhino* libmfcr2 lzop perl-HTML-TokeParser-Simple perl-WWW-Mechanize ?? te adjunto la captura de la pantalla luego de ejecutar ese comando [​IMG]

    gracias!!!
     
  10. jcastellanos

    Joined:
    Feb 10, 2009
    Messages:
    2,404
    Likes Received:
    0
    no, es correcto, no se si sea por la vercion del elastix, dejame checar te digo en un rato
     
  11. jpagarcia

    Joined:
    Jun 20, 2009
    Messages:
    17
    Likes Received:
    0
    espero, muchas gracias!
     
  12. jpagarcia

    Joined:
    Jun 20, 2009
    Messages:
    17
    Likes Received:
    0
    Jorge, hay alguna novedad de esto? Estuve viendo en otros lugares que para algunos modelos de mother, discos, etc esta instalación no funciona correctamente, podrá ser esto? lo que me desconcierta es que no me da ningún error...

    gracias
     
  13. jcastellanos

    Joined:
    Feb 10, 2009
    Messages:
    2,404
    Likes Received:
    0
    no, no creo que sea tu caso, ya lo tienes instalado, yo me imagino que es por la vercion de elastix (1.2) que es la que intentas instalar
     
  14. jpagarcia

    Joined:
    Jun 20, 2009
    Messages:
    17
    Likes Received:
    0
    estoy instalando elastix 1.2 pero x86 64 bits, dado que el procesador es de 64 bits, pensaba probar con el otro... qué me recomendás?
     
  15. jcastellanos

    Joined:
    Feb 10, 2009
    Messages:
    2,404
    Likes Received:
    0
    si definitivamente prueba con el de 32 bits, aunque yo recomendaria por mucho instales la vercion 1.5-2 completa del elastix, la cual es centos 5.2
     
  16. jpagarcia

    Joined:
    Jun 20, 2009
    Messages:
    17
    Likes Received:
    0
  17. jcastellanos

    Joined:
    Feb 10, 2009
    Messages:
    2,404
    Likes Received:
    0
    no, no creo, es centos para 64 bits?
     
  18. jpagarcia

    Joined:
    Jun 20, 2009
    Messages:
    17
    Likes Received:
    0
    Si, es centos para 64 bits
     
  19. jcastellanos

    Joined:
    Feb 10, 2009
    Messages:
    2,404
    Likes Received:
    0
    hai puede estar el problema, intenta montarlo en centos para 32 bits, con fin de pruebas, incluso haslo en una maquina virtual para no tocar tu server
     
  20. jpagarcia

    Joined:
    Jun 20, 2009
    Messages:
    17
    Likes Received:
    0
    Jorge, voy a intentarlo y te cuento como me fué.
    gracias!
     

Share This Page