incoming DID not working

icenews

Joined
Sep 3, 2010
Messages
37
Likes
0
Points
0
#1
Hi

I dont understand why things simply do not work

I installed PBX in a Flash two years ago - and obviously it took some work, but not like installing Elastix. What is the problem here - is it DAHDI as compared to Zaptel that is causing the problem ? Is it Asterisk 1.6 as compared to 1.4. What gives ?

Anyway - I installed the latest Elastix 2.02 4 times already. and I can not get incoming DID to route at all.

I have a kinda PRI from XO using traditional E&M signaling coming in connected to a Sangoma A102D card (upgraded firmware to 37). I followed the "out of date" Sangoma instructions in setting up Wanpipe, and still no solution

I can call out (without a ring tone mind you - but I can dial out at least) but incoming calls are not working at all. I get a busy signal, I get a message saying the calling number is not in services. I've tried it all. It just doesn't work. it has something to do with the Zaptel.conf (if there is any) or Dahdi.conf (dont know)

What am I missing ? Any help is appreciated.

Thanks
Walt
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#2
These might be hard words for PaloSanto, but Elastix 2.0.? is IMHO not stable yet, if this is a new install, may I ask you to spend another 45 minutes and try Elastix 1.6 latest iso, it is generally "solid as a rock", please report back as to any problems, the upgrade path to 2.0 when it actually works will apparently be available "some time soon".

dicko
 

icenews

Joined
Sep 3, 2010
Messages
37
Likes
0
Points
0
#3
hi

Thank you for this information

I will try 1.6 instead - thank you

but why does PaloSanto say 2.02 is "stable" in its descriptive download section
it should be removed and renamed "beta"

Thank you for the info

I will try 1.6 and keep you posted

Thanks
Walt
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#4
I can't answer as to the official PaloSanto position, and I obviously and patently disagree with it, I can only answer to my personal experiences.

I have supported Elastix for quite some time now, it really has been rock-solid for a while, but I am not in the position at this point in time to endorse 2.0, hence my request that you revert to a "tried and true" solution, there the knowledge-base is far more robust and reliable, and hopefully we can get you up and working, I am a pragmatist not an apologist. I assume you also want to "just make it work".

dicko

p.s. zaptel is now dahdi, even in 1.6
 

icenews

Joined
Sep 3, 2010
Messages
37
Likes
0
Points
0
#5
Hi

I have isntalled 1.6, and abuot ready to my tests

but where is the Call Center Module ?

Thank you
Walt
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#6
What has that got to do with ". .incoming DID not working . ."

that's a new thread, but you can get it from:

http://www.elastix.org/en/downloads/extras.html

A belated welcome, but please use the resources available here first, there are many, and preferably research them before you ask a question that has been asked at least 200 times before :)

dicko
 

icenews

Joined
Sep 3, 2010
Messages
37
Likes
0
Points
0
#7
hi

well I tried to dial out - this time I get a Ring Tone,
and system seems more responsive

However - the Incoming phone call did not work.

I get a message

"msl 04 call cannot be completed at this time - please try again later"

Something is still not setup correctly

Thanks
Walt
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#8
You are probably correct with the " .. . Something is still not setup correctly. . ."
although I don't recognize where

"msl 04 call cannot be completed at this time - please try again later"
came from

start with "Elastix Without Tears"

and concentrate on setting your inbound routes, (you will need them) start with a catchall route until you get comfortable with everything.

If you have e&m wink signaling on a "super-trunk" from XO expect only the last few digits on DID , you will need to route them as appropriate, similarly your outbound CID might well have to match what they will accept from you.
 

icenews

Joined
Sep 3, 2010
Messages
37
Likes
0
Points
0
#9
hi

I ran asterisk -r

and I see on the screen the following:

Starting simple switch on DAHDI/1-1
Hungup DAHDI/1-1

What does this mean ?
Is it hanging up the call ?

Thanks
Walt
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#10
yes, it is hanging up.

check with XO what signaling to expect from them and set it up in chan_dahdi.conf and /etc/dahdi/system.conf

from how you describe it (a traditional bidirectional super-trunk) , it might well be

signalling=em_w

(Ear and mouth - wink)

it might equally be something else

If you have no idea about what I am talking about, then you will have to learn, sorry.

dicko
 

icenews

Joined
Sep 3, 2010
Messages
37
Likes
0
Points
0
#11
Hi

I put the old system back on for now until tomorrow night.
(PBX in a Flash) is working now until tomorrow night when I will try once again

I have selected E&M when setting up Elastix

How do I check on the old system as to what it is set at
(either E&M or E&M Wink - not sure)
at one point, I did try both setting, but did not seem to make a difference.

I believe it is zaptel.conf on the old system - is this correct ?
what directory is it in ?

Thanks
Walt
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#12
in the the old (zaptel) system

/etc/zaptel.conf (for the hardware driver defs)
and
/etc/asterisk/zapata* (for the asterisk software driver defs)

in the new (dahdi) system

/etc/dahdi/system.conf
and
/etc/asterisk/dahdi_chan*
and
/etc/asterisk/chan_dahdi*


go to http://voip-info.org for basic definitives, go to XO for your authoritatives.

dicko
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,915
Messages
130,920
Members
17,591
Latest member
dalibor66
Top