Incoming call rejected - extension not found

Discussion in 'General' started by pinazo, Sep 6, 2010.

  1. pinazo

    Joined:
    Aug 12, 2010
    Messages:
    19
    Likes Received:
    0
    I created an alias at Sipbroker.com that forwards calls to my URI (myextension@myhome.dyndns.org)

    I created a SIP trunk called sipbroker
    type=peer
    fromuser=myCallcentricID
    fromdomain=callcentric.com
    host=sipbroker.com
    port=5060
    incominglimit=3
    insecure=invite
    nat=yes
    canreinvite=no

    In sip_custom.conf I put this:
    [sipbroker]
    host=sipbroker.com
    type=peer
    context=sipbroker-in
    insecure=very

    In extensions_custom.conf I put this:
    [sipbroker-in]
    exten => _X.,Dial(204)
    exten => _X.,Dial(205)

    204 and 205 are the extensions in my PBX.
    When someone calls from PSTN to a sipbroker access number and dials my alias, the call should ring at my extension (204). Instead, the caller receives busy tone, and I see this in the Asterisk Log:
    [2010-09-05 20:17:32] NOTICE[2824] chan_sip.c: Call from 'sipbroker' to extension '204' rejected because extension not found in context 'sipbroker-in'.

    Is it something wrong in the sipbroker-in context at extensions_custom.conf? It used to work, and one day it stopped working! Odd...
    I have Elastix 2.0

    Thanks!
     
  2. pinazo

    Joined:
    Aug 12, 2010
    Messages:
    19
    Likes Received:
    0
    Well... the book 'Asterisk, the future of telephony', had the answer:
    the proper method was writing the commands in the sipbroker-in context this way:

    exten => 204,1,Dial(SIp/204)
    exten => 205,1,Dial(IAX2/205)

    Being 204 a SIP extension and 205 a IAX2 extension.

    Regards
     
  3. andyshawn

    Joined:
    Apr 3, 2009
    Messages:
    113
    Likes Received:
    0
    Yes, i do agree with you pinazo. I normally write my config like this.

    exten => 204,1,Dial(SIP/204,20,r)
    exten => 204,2,Hangup
     
  4. pinazo

    Joined:
    Aug 12, 2010
    Messages:
    19
    Likes Received:
    0
    Thanks for your answer.
    I typed it your way.

    But it seems that is not the problem, because the next day the same problem appeared again...

    UPDATE:
    This setting was missing in SIP_general_additional.conf:
    nat=yes
    externhost=myDynDNS_account
    localnet=The_IP_range_of_my_network/255.255.255.0
    externrefresh = 60
    context=from-trunk

    Now everything is working OK
     

Share This Page