Incoming call issues

Discussion in 'General' started by seaq, Feb 5, 2010.

  1. seaq

    Joined:
    Sep 17, 2008
    Messages:
    41
    Likes Received:
    0
    Hi my friends;


    I'm having a serious trouble with incoming calls after update Elastix from 1.3 to the last 1.5 version.

    When I call to the PBX, the IVR responds succesfully; but when i introduce a digit (1,2 or 3) the announcement don't stops (does not obey or listen). Instead the call deviates to Operator queue or other extension.

    I've attempted changing the dahdi_channels.conf (echocancel=off and relaxdtmf=yes) but nothing.

    I've set the codecs for the extensions to ulaw and alaw, disallowing all; and anything either.

    This happens regardless I'm using Announcement in Background.


    I appreciate your help.


    Thanks in advance.
     
  2. seaq

    Joined:
    Sep 17, 2008
    Messages:
    41
    Likes Received:
    0
    Hi;

    I've added a setting into chan_dahdi.conf, and i believe that it resolves the issue partially:

    [channels]
    context=from-pstn
    signalling=fxs_ks
    rxwink=300 ; Atlas seems to use long (250ms) winks
    usecallerid=yes
    hidecallerid=no
    callwaiting=yes
    usecallingpres=yes
    callwaitingcallerid=yes
    threewaycalling=yes
    transfer=yes
    canpark=yes
    cancallforward=yes
    callreturn=yes
    echocancel=no
    echocancelwhenbridged=yes
    faxdetect=incoming
    echotraining=800
    rxgain=-6.0
    txgain=0.0
    callgroup=1
    pickupgroup=1
    language=es

    Now, the issue is the echo in all extensions. However,note that the rxgain setting was modified to -6.0. With the last parameter applied in chan_dahdi.conf, and doing the same in the Linksys SPA-942 phones, the echo reduces substantially; but i don't believe that it's the better solution.

    It's important to note that this is occurring after the upgrade of Elastix from 1.3 to 1.5.

    I appreciate your opinions.

    Thanks a lot.
     
  3. seaq

    Joined:
    Sep 17, 2008
    Messages:
    41
    Likes Received:
    0
    Indeed, although the IVR accepts digits correctly, the calls are hearing with echo.

    I think that might be DTMF settings in Asterisk; but i don't know how to do it.

    Any suggestions?

    Greetings.
     

Share This Page