Inbound calls hanging up after 20 seconds/minute

Discussion in 'General' started by sohaibwcws, Dec 10, 2008.

  1. sohaibwcws

    Joined:
    Sep 28, 2008
    Messages:
    6
    Likes Received:
    0
    We're experiencing an issue where inbound calls hang up after about 20 seconds or so. We can talk to the person for about 15 seconds and then they're just GONE there is no response just gone. I am using VOIP.MS VOIP.MS works just fine with other open source PBX like Callbuttler and other windows based just Asterisk based PBX is having some serious problem.

    I have set my trunks, my extensions and my call come in queue style and I do record calls for sales purpose.

    Here are the logs. Thanks!

    == Manager 'admin' logged off from 127.0.0.1
    -- AGI Script dialparties.agi completed, returning 0
    -- Executing [s@macro-dial:7] Dial("SIP/129352378-0a1abcc8", "SIP/200&SIP/201&SIP/202&SIP/204|20|trM(auto-blkvm)") in new stack
    -- Called 200
    -- Called 201
    -- Called 202
    -- Called 204
    -- SIP/201-0a10a198 is ringing
    -- SIP/200-0a1840d8 is ringing
    -- SIP/202-0a10e110 is ringing
    -- SIP/204-0a10f6a0 is ringing
    -- SIP/204-0a10f6a0 answered SIP/129352378-0a1abcc8
    -- Executing [s@macro-auto-blkvm:1] Set("SIP/204-0a10f6a0", "__MACRO_RESULT=") in new stack
    -- Executing [s@macro-auto-blkvm:2] Set("SIP/204-0a10f6a0", "__CWIGNORE=") in new stack
    -- Executing [s@macro-auto-blkvm:3] DBdel("SIP/204-0a10f6a0", "BLKVM/600/SIP/129352378-0a1abcc8") in new stack
    -- DBdel: family=BLKVM, key=600/SIP/129352378-0a1abcc8

    ********** NOTE THIS IS WHERE THE CALL HANGS UP ***********

    == Spawn extension (macro-dial, s, 7) exited non-zero on 'SIP/129352378-0a1abcc8' in macro 'dial'
    == Spawn extension (macro-dial, s, 7) exited non-zero on 'SIP/129352378-0a1abcc8'
    -- Executing [h@macro-dial:1] Macro("SIP/129352378-0a1abcc8", "hangupcall") in new stack
    -- Executing [s@macro-hangupcall:1] ResetCDR("SIP/129352378-0a1abcc8", "w") in new stack
    -- Executing [s@macro-hangupcall:2] NoCDR("SIP/129352378-0a1abcc8", "") in new stack
    -- Executing [s@macro-hangupcall:3] GotoIf("SIP/129352378-0a1abcc8", "1?skiprg") in new stack
    -- Goto (macro-hangupcall,s,6)
    -- Executing [s@macro-hangupcall:6] GotoIf("SIP/129352378-0a1abcc8", "0?skipblkvm") in new stack
    -- Executing [s@macro-hangupcall:7] NoOp("SIP/129352378-0a1abcc8", "Cleaning Up Block VM Flag: BLKVM/600/SIP/129352378-0a1abcc8") in new stack
    -- Executing [s@macro-hangupcall:8] DBdel("SIP/129352378-0a1abcc8", "BLKVM/600/SIP/129352378-0a1abcc8") in new stack
    -- DBdel: family=BLKVM, key=600/SIP/129352378-0a1abcc8
    -- DBdel: Error deleting key from database.
    -- Executing [s@macro-hangupcall:9] GotoIf("SIP/129352378-0a1abcc8", "1?theend") in new stack
    -- Goto (macro-hangupcall,s,11)
    -- Executing [s@macro-hangupcall:11] Hangup("SIP/129352378-0a1abcc8", "") in new stack
    == Spawn extension (macro-hangupcall, s, 11) exited non-zero on 'SIP/129352378-0a1abcc8' in macro 'hangupcall'
    == Spawn extension (macro-hangupcall, s, 11) exited non-zero on 'SIP/129352378-0a1abcc8'
     
  2. sohaibwcws

    Joined:
    Sep 28, 2008
    Messages:
    6
    Likes Received:
    0
    I notice that DBDEL : Error deleting key from database why is thta happening.
     

Share This Page