Inbound call problem

Discussion in 'General' started by nainala, Sep 30, 2010.

  1. nainala

    Joined:
    Jun 10, 2010
    Messages:
    16
    Likes Received:
    0
    Hi
    I have configured Openvox A400P 4FXO card in elastix 1.5.2
    i am not getting inbound calls but i able to get the outbound calls
    please help any one
     
  2. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    Give more details about the issue. What happens when some one dials to your phone lines? Busy tone? Any message? Anything else?
    Also paste the CLI (asterisk -r)output when a call arrives from the beginning up tp the end.
     
  3. tsku

    Joined:
    Oct 1, 2010
    Messages:
    62
    Likes Received:
    0
    have you configure your inbound route?
     
  4. nainala

    Joined:
    Jun 10, 2010
    Messages:
    16
    Likes Received:
    0
    Hi when some one dials to our phone line we are getting a message as "The number you have dialed not in service"
    Here i am pasting CLI output

    Starting simple switch on 'DAHDI/1-1'
    -- Executing [s@from-pstn:1] NoOp("DAHDI/1-1", "No DID or CID Match") in new stack
    -- Executing [s@from-pstn:2] Answer("DAHDI/1-1", "") in new stack
    -- Executing [s@from-pstn:3] Wait("DAHDI/1-1", "2") in new stack
    -- Executing [s@from-pstn:4] Playback("DAHDI/1-1", "ss-noservice") in new stack
    -- <DAHDI/1-1> Playing 'ss-noservice.gsm' (language 'en')
    -- Executing [s@from-pstn:5] SayAlpha("DAHDI/1-1", "") in new stack
    -- Executing [s@from-pstn:6] Hangup("DAHDI/1-1", "") in new stack
    == Spawn extension (from-pstn, s, 6) exited non-zero on 'DAHDI/1-1'
    -- Executing [h@from-pstn:1] Hangup("DAHDI/1-1", "") in new stack
    == Spawn extension (from-pstn, h, 1) exited non-zero on 'DAHDI/1-1'
    -- Hungup 'DAHDI/1-1'

    But when iam configuring anydid/anycid i am able to get the inbound call
     
  5. mm.alpha2k

    Joined:
    Jun 19, 2010
    Messages:
    165
    Likes Received:
    0
    Re: Re:Inbound call problem

    You've got two options

    1) Zap Channel DIDs allow you to assign a DID to specific Zap Channels. You can supply the same DID to multiple channels. This would be a common scenario if you have multiple POTS lines that are on a hunt group from your provider. You MUST assign the channel's context to from-zaptel for these settings to have effect. It will be a line that looks like:

    context = from-zaptel

    in your chan_dahdi.conf configuration effecting the specified channel(s). Once you have assigned DIDs you can use standard Inbound Routes with the specified DIDs to route your calls.

    2) Configuring any did = "s"
     
  6. Pinkus

    Joined:
    Oct 26, 2011
    Messages:
    45
    Likes Received:
    0
    Re: Re:Inbound call problem

    Hi , I have the same issue with Elastix 2.2
    Could anybody post simple step by step on how to solve this?
    I changed the files but I thing that I am doing something wrong at the ZAP Channels DID menu
    many thnaks
     

Share This Page