inbound call problem

Discussion in 'General' started by xedlinux, Apr 27, 2009.

  1. xedlinux

    Joined:
    Apr 24, 2009
    Messages:
    17
    Likes Received:
    0
    Hi,

    I just installed and make a testing with elastix.
    i am using : elastix-1.3-2

    I can make outbound calls but my inbound calls does not goes tru to extensions i specify in the ring group.

    cli logs are the following:

    Executing [16503881092@from-sip-external:1] NoOp("SIP/5060-09fe4dd0", "Received incoming SIP connection from unknown peer to 16503881092") in new stack
    -- Executing [16503881092@from-sip-external:2] Set("SIP/5060-09fe4dd0", "DID=16503881092") in new stack
    -- Executing [16503881092@from-sip-external:3] Goto("SIP/5060-09fe4dd0", "s|1") in new stack
    -- Goto (from-sip-external,s,1)
    -- Executing [s@from-sip-external:1] GotoIf("SIP/5060-09fe4dd0", "0?from-trunk|16503881092|1") in new stack
    -- Executing [s@from-sip-external:2] Set("SIP/5060-09fe4dd0", "TIMEOUT(absolute)=15") in new stack
    -- Channel will hangup at 2009-04-27 20:35:27 UTC.
    -- Executing [s@from-sip-external:3] Answer("SIP/5060-09fe4dd0", "") in new stack
    -- Executing [s@from-sip-external:4] Wait("SIP/5060-09fe4dd0", "2") in new stack
    -- Executing [s@from-sip-external:5] Playback("SIP/5060-09fe4dd0", "ss-noservice") in new stack
    -- <SIP/5060-09fe4dd0> Playing 'ss-noservice' (language 'en')
    -- Executing [s@from-sip-external:6] PlayTones("SIP/5060-09fe4dd0", "congestion") in new stack
    -- Executing [s@from-sip-external:7] Congestion("SIP/5060-09fe4dd0", "5") in new stack

    pbx*CLI>
    pbx*CLI>
    == Spawn extension (from-sip-external, s, 7) exited non-zero on 'SIP/5060-09fe4dd0'
    -- Executing [h@from-sip-external:1] NoOp("SIP/5060-09fe4dd0", "Hangup") in new stack
    -- Executing [h@from-sip-external:2] Set("SIP/5060-09fe4dd0", "DID=s") in new stack
    -- Executing [h@from-sip-external:3] Goto("SIP/5060-09fe4dd0", "s|1") in new stack
    -- Goto (from-sip-external,s,1)
    -- Executing [s@from-sip-external:1] GotoIf("SIP/5060-09fe4dd0", "0?from-trunk|s|1") in new stack
    -- Executing [s@from-sip-external:2] Set("SIP/5060-09fe4dd0", "TIMEOUT(absolute)=15") in new stack
    -- Channel will hangup at 2009-04-27 20:35:39 UTC.
    -- Executing [s@from-sip-external:3] Answer("SIP/5060-09fe4dd0", "") in new stack
    == Spawn extension (from-sip-external, s, 3) exited non-zero on 'SIP/5060-09fe4dd0'


    Please help whats wrong with this one.

    Thanks a lot.
     
  2. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    What is the DID that you have defined on your outbound routes?
    I can see that the DID that Elastix is getting is 16503881092
    I would also recommend you to edit /etc/asterisk/sip_general_custom.conf
    and write the following:
    context=from-pstn
    and then execute from the the shell:
    asterisk -rx "reload"
     
  3. asepulveda

    Joined:
    Jun 23, 2008
    Messages:
    400
    Likes Received:
    0
    Did you make you inbound routes with this DID 16503881092??, not all telcos sent the same quantity of digits for DID , in your case your telco is sending 16503881092 , so you must use this hole number to make inbound routes ,
     

Share This Page