IAX2 Trunk to PRI Outbound CID Caller ID question

finisproductions

Joined
May 4, 2010
Messages
8
Likes
0
Points
0
#1
Hello forum, I have an issue which I have tried to research but have not resolved. My setup is as follows: I have an Elastix system at location A which terminates to the PSTN via PRI/T1 lines. I have another Elastix system in location B which is connected via IAX2 trunking so that all outbound calls are sent out through location A's PRI/T1's.

The outbound CallerID fields on all location B extensions are set to the correct CID, and the Outbound CID for the IAX2 trunk is also set this way. However when I place outbound calls from location B through the location A's PRI/T1 it is sending out our default CID and not the CID I have setup on the IAX2 trunk.

Is there any way I can determine where the CID information is being mishandled or passed incorectly? I am a novice user but can certainly post information from the command line if I know what to look for.

Any help on resolving this issue is much appreciated.
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#2
Is the outbound route that sends those calls through that trunk, set as an "intra Company Route"?
 

finisproductions

Joined
May 4, 2010
Messages
8
Likes
0
Points
0
#3
Actually I have two outbound routes setup, one with dial patterns for our office A extensions where the intra company route box is ticked and the other is setup with normal dial patterns and the intra company route box is not ticked.

If it is helpful information to add, the IAX2 trunk is set up exactly according to the Elastix Blog article here:

http://blogs.elastix.org/en/2009/11/int ... astix-iax/

Thanks for your help.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,901
Messages
130,885
Members
17,562
Latest member
colak
Top