IAX2 Trunk Not Registering

Discussion in 'General' started by izrunas, Aug 22, 2010.

  1. izrunas

    Joined:
    Mar 4, 2009
    Messages:
    94
    Likes Received:
    0
    I am trying to get an IAX2 trunk connection to my IAX2 provider, les.net, working on Elastix 2.0 with FreePBX 2.8. I have years of happy experience dealing with les.net, so I am confused by the difficulty I am having this time. Here is what I have done so far:

    --Port 4569 is port forwarded to the new PBX
    --"requirecalltoken=no" added to iax_custom.conf
    --Trunk definition set precisely as les.net directs:

    Trunk Name = [number provided by les.net]

    PEER Details:

    host=did.voip.les.net
    context=from-trunk
    type=peer
    insecure=very
    nat=yes
    canreinvite=no
    username=[trunk name]
    secret=[password]

    USER Context = from-trunk

    USER Details:

    context=from-trunk
    type=user
    insecure=very
    nat=yes
    canreinvite=no

    Register String = [trunk name]:[password]@did.voip.les.net


    Anyone have some insight into this? It's really perplexing me... Thanks in advance!
     
  2. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    Hi izrunas,
    Can you see your trunk registered with 'iax2 show peers' ?
    Have you tried to enable iax2 debugging? Do you see any errors there??
     
  3. izrunas

    Joined:
    Mar 4, 2009
    Messages:
    94
    Likes Received:
    0
    I was about to dump a whole bunch of command line results as a reply, but suddenly and inexplicably, it started working. :)
     
  4. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    Wellcome to Elastix ;)
     

Share This Page