IAX2 extension always busy

javerleo

Joined
Nov 17, 2014
Messages
4
Likes
0
Points
1
#1
Hello.

We are using Elastix 4.0. Everything works fine so far, but we couldn't make use of a IAX2 phone CooFone-D30. Outgoing calls work fine for both internal and external destinations, but whenever you make a call to that phone/extension you always get a "busy/congested" answer. We activated IAX2 debug for that extension and there is an error message about no called number been passed, but we couldn't find any explanation of the cause of that error on IAX2 protocol documentation. I will paste here the relevant log:

-- Goto (macro-dial-one,s,43)
-- Executing [s@macro-dial-one:43] Dial("SIP/102-000000ec", "IAX2/116,,tr") in new stack
Tx-Frame Retry[000] -- OSeqno: 000 ISeqno: 000 Type: IAX Subclass: NEW
Timestamp: 00016ms SCall: 03807 DCall: 00000 [201.244.177.159:14569]
VERSION : 2
CALLED NUMBER : s
CODEC_PREFS : (ulaw|alaw|gsm)
CALLING NUMBER : 102
CALLING PRESNTN : 0
CALLING TYPEOFN : 0
CALLING TRANSIT : 0
CALLING NAME : 102
LANGUAGE : en
FORMAT : 4
FORMAT2 : ulaw
CAPABILITY : 14
CAPABILITY2 : Unknown
ADSICPE : 2
DATE TIME : 2018-10-17 11:00:38

-- Called IAX2/116
Rx-Frame Retry[ No] -- OSeqno: 000 ISeqno: 001 Type: IAX Subclass: ACK
Timestamp: 00016ms SCall: 16439 DCall: 03807 [201.244.177.159:14569]
Rx-Frame Retry[ No] -- OSeqno: 000 ISeqno: 001 Type: IAX Subclass: REJECT
Timestamp: 01000ms SCall: 16439 DCall: 03807 [201.244.177.159:14569]
CAUSE : Refuse call because no called number!

Tx-Frame Retry[-01] -- OSeqno: 001 ISeqno: 001 Type: IAX Subclass: ACK
Timestamp: 01000ms SCall: 03807 DCall: 16439 [201.244.177.159:14569]
-- Hungup 'IAX2/116-3807'
== Everyone is busy/congested at this time (1:0/0/1)
-- Executing [s@macro-dial-one:44] ExecIf("SIP/102-000000ec", "0?MacroExit()") in new stack
-- Executing [s@macro-dial-one:45] ExecIf("SIP/102-000000ec", "0?Set(DIALSTATUS=)") in new stack
-- Executing [s@macro-dial-one:46] GosubIf("SIP/102-000000ec", "0?s-CHANUNAVAIL,1()") in new stack
-- Executing [s@macro-dial-one:47] MacroExit("SIP/102-000000ec", "") in new stack
-- Executing [s@macro-exten-vm:8] Set("SIP/102-000000ec", "SV_DIALSTATUS=CHANUNAVAIL") in new stack
-- Executing [s@macro-exten-vm:9] GosubIf("SIP/102-000000ec", "0?docfu,1()") in new stack
-- Executing [s@macro-exten-vm:10] GosubIf("SIP/102-000000ec", "0?docfb,1()") in new stack
-- Executing [s@macro-exten-vm:11] Set("SIP/102-000000ec", "DIALSTATUS=CHANUNAVAIL") in new stack
-- Executing [s@macro-exten-vm:12] ExecIf("SIP/102-000000ec", "0?MacroExit()") in new stack
-- Executing [s@macro-exten-vm:13] GotoIf("SIP/102-000000ec", "1?s-CHANUNAVAIL,1") in new stack
-- Goto (macro-exten-vm,s-CHANUNAVAIL,1)
-- Executing [s-CHANUNAVAIL@macro-exten-vm:1] GotoIf("SIP/102-000000ec", "1?exit,1") in new stack
-- Goto (macro-exten-vm,exit,1)
 
Last edited:

ncortes1984

Contributor
Joined
Apr 24, 2019
Messages
3
Likes
0
Points
1
#2
Hello friend, I have the same problem and I have not solved the fault, by chance you have the solution. Thank you.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,981
Messages
131,060
Members
17,704
Latest member
Pahntom
Top