I need help with HFC-S Card Cisco BRI

Discussion in 'General' started by rob.neural, Feb 22, 2011.

  1. rob.neural

    Joined:
    Feb 22, 2011
    Messages:
    2
    Likes Received:
    0
    Hello everyone,

    after installing Elastix 2.0.3 I have the following problem by having installed a hfc-s card and connected with a cisco router with BRI card can not make outgoing calls but when I try to get incoming calls do not see anything and the cisco BRI is blocked. The card and cable are working on an installation asterisk because I have no problem with zaptel. Can you help me, thanks.

    My config...


    #dahdi_cfg -vvvvvvvvvv
    DAHDI Tools Version - 2.4.0

    DAHDI Version: 2.3.0.1
    Echo Canceller(s): OSLEC
    Configuration
    ======================

    SPAN 1: CCS/ AMI Build-out: 0 db (CSU)/0-133 feet (DSX-1)

    Channel map:

    Channel 01: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 01)
    Channel 02: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 02)
    Channel 03: Hardware assisted D-channel (Default) (Echo Canceler: none) (Slaves: 03)

    3 channels to configure.

    Setting echocan for channel 1 to oslec
    Setting echocan for channel 2 to oslec
    Setting echocan for channel 3 to none

    # dahdi_hardware
    pci:0000:00:0a.0 zaphfc+ 1397:2bd0 HFC-S ISDN BRI card

    #cat /etc/asterisk/chan_dahdi.conf
    [trunkgroups]

    [channels]

    language=it
    context=from-zaptel
    switchtype=euroisdn
    ;pridialplan=local
    ;prilocaldialplan=local
    internationalprefix = 00
    nationalprefix = 0
    signalling=bri_cpe
    rxwink=300 ; Atlas seems to use long (250ms) winks
    usecallerid=yes
    hidecallerid=no
    callwaiting=yes
    usecallingpres=yes
    callwaitingcallerid=yes
    threewaycalling=yes
    transfer=yes
    canpark=yes
    cancallforward=yes
    callreturn=yes
    echocancel=yes
    echocancelwhenbridged=yes
    echotraining=50
    rxgain=0.0
    txgain=0.0
    group=1
    callgroup=1
    pickupgroup=1
    immediate=no
    overlapdial=yes
    channel => 1-2
    musiconhold=default

    # cat /etc/asterisk/dahdi-channels.conf
    ; Autogenerated by /usr/sbin/dahdi_genconf on Tue Feb 22 09:54:53 2011
    ; If you edit this file and execute /usr/sbin/dahdi_genconf again,
    ; your manual changes will be LOST.
    ; Dahdi Channels Configurations (chan_dahdi.conf)
    ;
    ; This is not intended to be a complete chan_dahdi.conf. Rather, it is intended
    ; to be #include-d by /etc/chan_dahdi.conf that will include the global settings
    ;

    ; Span 1: ZTHFC1 "HFC-S PCI A ISDN card 0 [TE] " (MASTER) AMI/CCS
    group=0,11
    context=from-pstn
    switchtype = euroisdn
    signalling = bri_cpe
    channel => 1-2
    context = default
    group = 63

    # cat /etc/dahdi/system.conf
    # Autogenerated by /usr/sbin/dahdi_genconf on Tue Feb 22 09:54:53 2011
    # If you edit this file and execute /usr/sbin/dahdi_genconf again,
    # your manual changes will be LOST.
    # Dahdi Configuration File
    #
    # This file is parsed by the Dahdi Configurator, dahdi_cfg
    #
    # Span 1: ZTHFC1 "HFC-S PCI A ISDN card 0 [TE] " (MASTER) AMI/CCS
    span=1,1,0,ccs,ami
    # termtype: te
    bchan=1-2
    hardhdlc=3
    echocanceller=oslec,1-2

    # Global data

    loadzone = it
    defaultzone = it

    # cat /etc/dahdi/genconf_parameters
    echo_can oslec
    bri_sig_style bri
     
  2. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    what does #dahdi_tool option said to you about green or red status of the bri interface

    what about cli command bri show spans? and asterisk cli
     
  3. rob.neural

    Joined:
    Feb 22, 2011
    Messages:
    2
    Likes Received:
    0
    OK, i solved the problem with upgrade.

    Code:
    yum update -y --enablerepo=elastix-beta
    yum install -y kernel-module-dahdi-bri* --enablerepo=elastix-beta
    Thanks very much.
     

Share This Page