Hylafax t.38

Discussion in 'General' started by hetii, Sep 27, 2007.

  1. hetii

    Joined:
    Jun 7, 2007
    Messages:
    32
    Likes Received:
    0
    Hi

    i again have problem with faxes :)

    Im got from hylafax this message:

    Your job to 1234567890 was not sent because:
    No answer (T.30 T1 timeout)
    The job will be retried at 14:47

    when i try to send fax through my VoIP provider line when i use ZAP/g0 everything is ok.

    i Ask them why i cannot send and he tell me i must use t.38 protocol to communication with his gateway.

    So any idea ?
     
  2. accesip

    Joined:
    May 16, 2007
    Messages:
    113
    Likes Received:
    0
    Maybe codec used. Only G711 works.
    Brice
     
  3. lek

    lek Guest

    I think you have to set this flag:

    t38pt_udptl = yes

    in your sip.conf file.

    Please, keep me updated.
     
  4. hetii

    Joined:
    Jun 7, 2007
    Messages:
    32
    Likes Received:
    0
    Edgar :)

    I don`t have set this t38pt_udptl=yes
    but now i don`t have much time to test this options.
    (and why in sip.conf ? hylafax uses IAXmodem and t.30 protocol.)

    Now i test elastix 8.5.0 and freepbx 2.2.3 and i don`t now why i don`t get pdf file on e-mail when somebody send me fax(i use also hylafax for receiving).

    I see this received fax on FAX Visor. When i resolve this problem i will try run t.38 protocol on elastix.

    Regards.
     
  5. dacos1979

    Joined:
    Nov 1, 2007
    Messages:
    37
    Likes Received:
    0
    Hello i have the same problem when I use de fax module in regular PSTN it is OK, but when I try to use the FAX over IP PROVEEDOR, it doen't work. The line canreinvite=yes and t38pt_udptl=yes it enable, but i think the problem it's the codect T38. How can I resolv this problem? Thank you.
     
  6. DaveD

    Joined:
    Nov 12, 2007
    Messages:
    597
    Likes Received:
    0
    In sip.conf add to [general] context and to every peer context that you want to register in Asterisk to use T.38 the following lines:
    t38pt_udptl=yes
    t38pt_rtp=no
    t38pt_tcp=no

    In udptl.conf file I have the following configurations:
    [general]
    udptlstart=4000
    udptlend=4999
    T38FaxUdpEC = t38UDPRedundancy
    T38FaxMaxDatagram = 400
    udptlfecentries = 3
    udptlfecspan = 3
     
  7. dacos1979

    Joined:
    Nov 1, 2007
    Messages:
    37
    Likes Received:
    0
    Thank you for your early help, I am working in this issie, i had made the configuration, but now i have this error
    [Dec 3 20:25:52] WARNING[3923] chan_sip.c: Maximum retries exceeded on transmission 418C3B09-C0D911DD-8E65F0B8-9E7C049@10.8.38.185 for seqno 102 (Critical Response)
    [Dec 3 20:25:52] WARNING[3923] chan_sip.c: Hanging up call 418C3B09-C0D911DD-8E65F0B8-9E7C049@10.8.38.185 - no reply to our critical packet.

    What will be the problem?

    Thank you.
     
  8. DaveD

    Joined:
    Nov 12, 2007
    Messages:
    597
    Likes Received:
    0
    There is a patch from digium that needs to be compiled in.

    At the moment I don't have the link handy, will post when I get a chance or someone might have the link handy
     

Share This Page