Hylafax modem wedged error after deleting a fax

striderec

Joined
Nov 25, 2008
Messages
105
Likes
0
Points
16
#1
Hi there,

I deleted an E-fax from the Elastix web interface that I needed no more and now Hylafax is bombing me every five minutes with this:


The HylaFAX software thinks that there is a problem with the modem on device /dev/ttyIAX5 that needs attention; repeated attempts to initialize the modem have failed.

Consult the server trace logs for more information on what is happening.

You will be notified again after 5 minutes if the problem persists.

/dev/ttyIAX5 exists no more because I delete it from the Elastix WebUI. I think someone said a while ago that Elastix had a bug that would not delete an e-fax properly.

What should I do to solve this problem and stop this nightmare of getting hundreds of mails a day from Hylafax?

Best Regards,

Paul
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#2
There will be three references to ttyIAX5 in your system (actually four but one is a log file and is specious here)

in /etc/inittab

is a line that will "start" the no longer defined driver, which was defined in

/var/log/iaxmodem/iaxmodem-cfg.ttyIAX5

hylafax will use it's own knowledge of this once extant device from the file:-

/var/spool/hylafax/etc/config.ttyIAX5

to "know" about it, it will bitch if it's not there or not working. (faxstat from bash)



if you used Elastix to "delete" such a device and any one of these entities still exist, then please post a bug in the bug-tracker link below,

However, if in fact there is a bug, i.e. Elastix did NOT properly remove the device that you asked it to , then in the presence of any of these three entities,then I humbly suggest you preemptively "fix that crap" and then from bash:-

init q
service iaxmodem restart
service hylafax restart

this should "fix their shit" until they do it themselves.

dicko
 

striderec

Joined
Nov 25, 2008
Messages
105
Likes
0
Points
16
#3
Thank you Dicko,

1) On /etc/inittab I found this:

# Don't remove or modify this comment. The following block is for fax setup.
fx7:2345:respawn:/usr/sbin/faxgetty ttyIAX7
fx5:2345:respawn:/usr/sbin/faxgetty ttyIAX5 <--- DELETED MODEM!!
fx4:2345:respawn:/usr/sbin/faxgetty ttyIAX4
fx2:2345:respawn:/usr/sbin/faxgetty ttyIAX2
fx3:2345:respawn:/usr/sbin/faxgetty ttyIAX3
fx1:2345:respawn:/usr/sbin/faxgetty ttyIAX1

2) On /var/log/iaxmodem :

[root@ippbx hylafax]# cd /var/log/iaxmodem/
[root@ippbx iaxmodem]# ls
iaxmodem iaxmodem-cfg.ttyIAX3 iaxmodem-cfg.ttyIAX6
iaxmodem-cfg.ttyIAX1 iaxmodem-cfg.ttyIAX4 iaxmodem-cfg.ttyIAX7
iaxmodem-cfg.ttyIAX2 iaxmodem-cfg.ttyIAX5
[root@ippbx iaxmodem]#

ttyIAX5 is still there!!!

3) On /var/spool/hylafax/etc :

[root@ippbx iaxmodem]# cd /var/spool/hylafax/etc/
[root@ippbx etc]# ls
abackup config.ttyIAX6 FaxDictionary setup.cache
config config.ttyIAX7 FaxDictionary.rpmorig templates
config.rpmsave cover.templ FaxDispatch xferfaxlog
config.ttyIAX1 dialrules hosts.hfaxd xferfaxlog.1.gz
config.ttyIAX2 dialrules.europe lastrun xferfaxlog.2.gz
config.ttyIAX3 dialrules.sf-ba lutRS18.pcf xferfaxlog.3.gz
config.ttyIAX4 dpsprinter.ps #sample.config.ttyIAX
[root@ippbx etc]#

Not there!!

So 1 out of 3 Dicko, and yes i used Elastix to delete that fax. I will have to report the bug to the development team.

In the meantime I will manually delete these entries.

Thank you very much and Happy New Year!

- Paul
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#4
my apologies, i mentioned the unnecessary log file, I should have said


iaxmodem-cfg.ttyIAX5


in /etc/iaxmodem/

please delete if present. but of course for completeness also the log file.

p.s.

how did you previously partially remove ttyIAX6 ?
 

striderec

Joined
Nov 25, 2008
Messages
105
Likes
0
Points
16
#5
Dicko:

I noticed the missing file for ttyIAX6 but the odd thing is that this fax is still on the system. I guess that is why the Elastix web interface says that the modem is trying to initialize but it never goes beyond that point.

Would it be that the Elastix script deleted the wrong modem and now that modem has a problem?

- Paul
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#6
When I saw 6 was gone (in some places) I must admit it occurred to me that perhaps PaloSanto can't count and the bug might be more insidious .
 

Members online

Latest posts

Forum statistics

Threads
30,898
Messages
130,879
Members
17,560
Latest member
manuelc
Top