Hylafax and Postfix

Discussion in 'General' started by rollinsolo, Jun 11, 2010.

  1. rollinsolo

    Joined:
    Feb 11, 2009
    Messages:
    279
    Likes Received:
    0
    I am having trouble with receiving the fax .pdf file to email, I got the VM to email working but it is giving an error when trying to send from=uucp@pbx.local which the authenticated mail server does not like it wants to see from=user@theirdomainemailaddress.com. I found the file in /var/spool/hylafax/faxrcvd and edited the FROMADDR=user@theirdomainemailaddress.com and restarted but the email still gets an error in the logs and is getting sent as from=uucp@pbx.local.

    Is there another file that someone knows about that is specifically for sending mail and formatting for Hylafax, the equivalent for voicemail is /etc/asterisk/vm_general.inc where you can change the serveremail= to the correct address for authenticated mail.

    Thanks all I will play over the weekend on this and report back if I don't hear from anyone.
     
  2. rollinsolo

    Joined:
    Feb 11, 2009
    Messages:
    279
    Likes Received:
    0
    Does anyone have any idea where to look or maybe it might be a permissions issue to make uucp send mail as root perhaps.
     
  3. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    I'm not completely understanding here, are you using the basic Elastix FAX wrapper of hylafax, or the more functional avantfax wrapper?

    what does (from bash)

    hostname

    return

    it should be what you have in

    /etc/sysconfig/network

    if it is:

    pbx.local

    then your mail system probably won't accept the emails, unless you allow relaying from that domain. It should probably be "theirdomainemailaddress.com" as long as theirdomainemailaddress.com is really theirdomain.com, (the email bit is to the left of the @ )



    dicko
     
  4. rollinsolo

    Joined:
    Feb 11, 2009
    Messages:
    279
    Likes Received:
    0
    Yes I am using the basic Built in Elastix Faxing, PRI, DID points to an IAX2 extension which points to a specific modem to an email (faxdispatch). and yes hostname does return companyA.pbx.local , and with the help of the postfixgmail.sh script we modified it to authenticate to a hosted mail server in the cloud for voicemail to email and in etc/postfix/generic we put @pbx.local companyAemailUser@companyAdomain.com and it worked like a charm.

    are you suggesting that I change the hostname in the web interface and postfix(where appropriate) to the email address we have used to authenticate the mail.
     
  5. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    I believe that the Elastix Fax system should use the settings set up in fax->Template email but to be quite honest it's been quite a while since I switched to AvantFAX

    Although your current generic address rewrite should work, I suggest you try, to expand the specific functionality of ramoncio's script to cover your particular situation. (one line)


    echo "uucp@pbx.local user@theirdomainemailaddress.com" >> /etc/postfix/generic; postmap /etc/postfix/generic ; /etc/init.d/postfix restart
     
  6. rollinsolo

    Joined:
    Feb 11, 2009
    Messages:
    279
    Likes Received:
    0
    Previously on LOST, jk, anyways I did try the generic postfix fix and added another entry for uucp@pbx.local to be seen as the authenticated email, but that didnt work, but what did work and also something I have overlooked for a couple of years myself was the template email and changed the parameters and the email goes out perfect now. +1 to you and the two handed bow as well. Thanks for responding as always.
     

Share This Page