how to upgrade asterisk core

Discussion in 'General' started by x0101222, Jan 17, 2010.

  1. x0101222

    Joined:
    Apr 26, 2009
    Messages:
    10
    Likes Received:
    0
    Hi.

    I agree that this task may be a easy yum command for most of the guys that know what to do, but for me is something to be done with a guideline.

    Facts: I have a problem in the play speed of the recorded calls, the recording is working ok for inbound and outbound calls, but the play is too fast and with "loss" segments of voice.

    I try to solve this issue with the google help but the changes that I made didn´t provide an solution..

    The best way is to upgrade the asterisk 1.4.22 core in a elastix 1.3.2 envoirement with freepbx2.6.0.

    could someone provide me the steps to perform an asterisk upgrade?

    I am happy with this server, elastix is great and all the tasks are working ok. I just need to solve this problem.

    Please help me, and I promise that I will write some words about my installation in the Success stories :)

    Many many thanks. Obrigado.

    Rui
     
  2. rafael

    Joined:
    May 14, 2007
    Messages:
    1,454
    Likes Received:
    1
    For updating asterisk:

    yum update asterisk

    For updating freepbx to 2.6 you would need to do it the freepbx way and it may break the embedded freepbx. I would recomend you do some testings on a virtual machine first.

    best regards,

    Rafael

    PS we have an Portuguesse mailing list here: http://lists.elastix.org/mailman/listinfo/general-pt
     
  3. x0101222

    Joined:
    Apr 26, 2009
    Messages:
    10
    Likes Received:
    0
    Thanks Rafael, I was afraid to have 5 or 6 commands but it appears to be a easy task.

    The freepbx is already the 2.6.0, I upgrade it via freepbx and everything is ongoing well.


    I will make a ghost of this disk and after try the yum update asterisk.

    I make the registration in the mail list, it will be a pleasure to help.


    Regards.

    Rui
     
  4. smith.alen

    Joined:
    Jan 19, 2010
    Messages:
    2
    Likes Received:
    0
    Hello,
    I new to Asterisk Pl. Help. I have asterisk 1.4.28 Version i want to upgarde 1.6 direct is it possible ???
    I m giving this command --- $yum update asterisk

    "Error: No Package Matching asterisk"

    Smith
     
  5. saleh

    Joined:
    Apr 18, 2007
    Messages:
    249
    Likes Received:
    0
    Elastix 2.0 support Asterisk 1.6 but currently in the Alpha stage

    Best Regards,
    Saleh
     
  6. rafael

    Joined:
    May 14, 2007
    Messages:
    1,454
    Likes Received:
    1
    There is not an easy way to update to Asterisk 1.6 now. You may search on the tips & tricks sections, there Chilling_silence post an article on how to do it. It was for a previous version of Elastix, but might work.

    Regards,

    Rafael
     

Share This Page