How to set up Voicemail-to-Email???

huntersx

Joined
Jan 25, 2010
Messages
12
Likes
0
Points
0
#1
I set /etc/postfix/main.cf Followed:
relayhost = smtp.163.com
smtpd_sasl_auth_enable = yes
smtpd_sasl_path = smtpd
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_type = cyrus
smtp_sasl_auth_enable = yes
# optional: necessary if email provider uses load balancing and
# forwards emails to another smtp server
# for delivery (ie: smtp.yahoo.com --> smtp.phx.1.yahoo.com)
smtp_cname_overrides_servername = no
# optional: necessary if email provider
# requires passwords sent in clear text
smtp_sasl_security_options = noanonymous

/etc/posftix/sasl_passwd
# The server info must exactly match the value
# for "relayhost" in /etc/postfix/main.cf
smtp.163.com huntersx:passwd
and try
smtp.163.com huntersx@163.com:passwd
but failed
/var/log/maillog show

Feb 22 19:39:05 server01 imap[30610]: login: server01 [127.0.0.1] huntersx.163.com plaintext User logged in
Feb 22 19:39:05 server01 imap[30619]: executed
Feb 22 19:39:05 server01 imap[30610]: seen_db: user huntersx^163^com opened /var/lib/imap/user/h/huntersx^163^com.seen
Feb 22 19:39:05 server01 imap[30610]: open: user huntersx^163^com opened INBOX
Feb 22 19:39:05 server01 imap[30610]: open: user huntersx^163^com opened Sent
Feb 22 19:39:05 server01 imap[30610]: open: user huntersx^163^com opened Trash
Feb 22 19:39:18 server01 postfix/pickup[29629]: 9708688695: uid=103 from=<asterisk>
Feb 22 19:39:18 server01 postfix/cleanup[30600]: 9708688695: message-id=<Asterisk-18-1661844858-3002-3939@server01>
Feb 22 19:39:18 server01 postfix/qmgr[26474]: 9708688695: from=<asterisk@example.com>, size=11598, nrcpt=1 (queue active)
Feb 22 19:39:34 server01 postfix/smtp[30602]: 9708688695: to=<huatang@itctl.com>, relay=smtp.163.com[220.181.12.11]:25, delay=16, delays=0.01/0/16/0.08, dsn=5.0.0, status=bounced (host smtp.163.com[220.181.12.11] said: 553 You are not authorized to send mail, authentication is required (in reply to MAIL FROM command))
Feb 22 19:39:35 server01 postfix/cleanup[30600]: 0999B88696: message-id=<20100222113935.0999B88696@elastix.example.com>
Feb 22 19:39:35 server01 postfix/qmgr[26474]: 0999B88696: from=<>, size=13575, nrcpt=1 (queue active)
Feb 22 19:39:35 server01 postfix/bounce[30638]: 9708688695: sender non-delivery notification: 0999B88696
 

huntersx

Joined
Jan 25, 2010
Messages
12
Likes
0
Points
0
#2
I already enable voicemail in web interface,but I haven't local SMTP server.
I need to use other SMTP Forward
 

huntersx

Joined
Jan 25, 2010
Messages
12
Likes
0
Points
0
#3
Nobody know and help me?????
 

Bob

Joined
Nov 4, 2007
Messages
2,400
Likes
1
Points
36
#4
Have a look at the Elastix Without Tears guide.

It has a section on Email setup.

I am a little sketchy lately, but you have correctly specified SASL, but if I remember, you need to create the password file using the command line tools...sorry short on time, otherwise would check for you....

Let us know if you still have issues....

Bob
 

huntersx

Joined
Jan 25, 2010
Messages
12
Likes
0
Points
0
#5
thank you for your help
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,900
Messages
130,884
Members
17,561
Latest member
marouen
Top