How to Prevent FollowMe from Prepending a "1"

daschenbrener

Joined
Aug 11, 2010
Messages
35
Likes
0
Points
0
#1
Does anyone have some direction on this problem/feature:

1. Why does FollowMe Prepend a "1" to outbound calls

2. How can this be changed to not prepend a digit when forwarding to an outbound number using followme?

Thanks in advance

David
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#2
It prepends nothing,

Follow-Me List:
List extensions to ring, one per line, or use the Extension Quick Pick below.

You can include an extension on a remote system, or an external number by suffixing a number with a pound (#). ex: 2448089# would dial 2448089 on the appropriate trunk (see Outbound Routing).

look at your outbound routes and trunks for any manipulations you might have already configured, this is where this will happen, only your trunk can add a 1 as yet not the outbound route.

program 1|NXXNXXXXXX as well as NXXNXXXXXX in you outbound routes/trunks if necessary for NANP land (Canada counts :) )
 

daschenbrener

Joined
Aug 11, 2010
Messages
35
Likes
0
Points
0
#3
I have tried that and it still appends the 1 and the + symbol.

only in followme

when using the trunk normally, it works fine.

Any other areas I should look would be appreciated.

Thanks
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#4
Believe me, it's not the follow-me, its your routing. please double check any other route manipulations you might have implemented.
 

daschenbrener

Joined
Aug 11, 2010
Messages
35
Likes
0
Points
0
#5
now when you are trouble shooting, where are you suggesting to look, freepbx?

or the raw config files? and if so which ones.
 

daschenbrener

Joined
Aug 11, 2010
Messages
35
Likes
0
Points
0
#6
I will pay you if you would like to look and fix
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#7
Follow the force, either temporally in the Asterisk CLI, or for less stress and for more stress free post mortem analysis, the file

/var/log/asterisk/full

I'm sorry, this forum is not, and I hope never will be, for commercial use, I must,and always will, thus decline your solicitation , PaloSanto offer Paid support however, conveniently in the "paid-support" link below :)

regards

dicko
 

daschenbrener

Joined
Aug 11, 2010
Messages
35
Likes
0
Points
0
#8
as i dig deeper, it also only happens when a incoming call comes in on a analog line though my openvox card, then the follow me goes out on a voip line.

if I have a incoming call on a voip line and out on a voip, i do not get the +1.

??
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#9
Sorry, I don't do OpenVox, they are rogue's and IMHO thieves and don't follow or obey any acceptable Asterisk conventions. ( I await the well named Belief Mo's rebuttal however :) )
 

daschenbrener

Joined
Aug 11, 2010
Messages
35
Likes
0
Points
0
#10
LOL, any suggestion (beside getting another card)
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#11
No, just get a REAL card :) they generally work within the mainstream Dahdi/Asterisk we all use without problems.

The clone market products no matter where they originate They are quiet spectacular in a microwave oven however, just like their kid's pajamas, would you trust that market?

(Believe M[eo] I've done it!!, have you?)
 

daschenbrener

Joined
Aug 11, 2010
Messages
35
Likes
0
Points
0
#12
K, Will do.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,901
Messages
130,885
Members
17,561
Latest member
marouen
Top