how to play IVR for Outbound call

Discussion in 'General' started by kareem, Jan 12, 2010.

  1. kareem

    Joined:
    Dec 9, 2009
    Messages:
    77
    Likes Received:
    0
    hi every body

    this a big problem i have read an article and this is apart of it

    Instead of connecting live callers to an agent when the phone is answered, outbound IVR applications use advanced speech recognition and dual tone multi frequency to help callers more easily interact with the automated system and complete transactions without the need for human assistance, or the systems can route live calls to agents when needed.

    knew any body knew how to do this


    thanks
     
  2. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    You use the originate command from the CLI, for example:
    originate Local/number_to_dial@from-internal extension s@ivr-2
    Where you have already created an ivr, and on the configuration file was named ivr-2.

    But if you want to do an automatic task, you may need to create an AGI, and do some programmaing using AMI functions, etc...

    As well, if you read this post, it may give you a clue on what you want:
    http://www.elastix.org/index.php?option ... mitstart=0
    http://www.elastix.org/component/option ... 0/lang,en/
     
  3. kareem

    Joined:
    Dec 9, 2009
    Messages:
    77
    Likes Received:
    0
    thank you jgutierrez

    it works

    by the way your answer was the first helpful answer i have :lol:
     
  4. kareem

    Joined:
    Dec 9, 2009
    Messages:
    77
    Likes Received:
    0
    it work and i'm very happy about it but

    there is a problem with the report

    when i made a campaign and the csv file has one number say 0162657845
    he will here my message and he may hangup before he goes to my extension or the agent who will receive the call

    the report will look like this
    Queue Type Phone Transfer Status
    600 Outbound 160926786 NoAnswer


    how can i make the duration of the call appearse in my report:dry:
     

Share This Page