How to monitor CUSTOM trunks?

txema

Joined
Jun 4, 2009
Messages
10
Likes
0
Points
0
#1
Hi,

I'm just trying to monitor CUSTOM type trunks under FOP. I'm using Elastix 1.5.2 and a Sangoma FlexiBRI B700 card (2xBRI, 2xFXO). The thing is that, to get the BRI ports to work with Asterisk, I have to define a CUSTOM trunk with the following definition: WOOMERA/g1/$OUTNUM$.
WOOMERA is the name of the asterisk channel that this card uses.

I've tried to specify this trunk in FOP in several ways (WOOMERA/g1, WOOMERA, WOOMERA/g1/$OUTNUM$, ...) but none works. The trunk shows up in FOP, but doesn't monitor the activity of the trunk.

Any ideas?
Thanks,


--
Txema
 

asternic

Joined
Jun 29, 2009
Messages
18
Likes
0
Points
0
#2
Hello,

FOP monitor channel names as reported by the Asterisk Manager Interface. You can start fop with debug set to one to see the manager events, and see how is asterisk naming the channels.

Fist stop fop as started by freebpx

/usr/sbin/amportal stop_fop

Then start fop with debug level set to one you have to run it from the command line like:

cd /var/www/html/panel
./op_server.pl -X 1

You can capture the output to some file because the manager is pretty verbose... then make some calls and see how asterisk is naming the channel (look for "Channel: TECH/XXXXX-YYYY" on the events.

FOP will match on "TECH/XXXX" . It does not use the session (YYYY) part of the name.

You can then use the proper name on the button definition to see if it works or not.

Best regards,
 

txema

Joined
Jun 4, 2009
Messages
10
Likes
0
Points
0
#3
Hi,

thanks for the input! I finally spent some time during past weeks tracing logs and testing several trunk names till I finally get it to work... more or less. I got a partial success though: FOP just monitors outgoing calls trough the custom type trunks, but not incoming.

I guess that has something to do with driver implementation, as this trunk uses a "woomera" type channel, which I suspect it's not that usual (used by Sangoma cards)... and maybe monitoring from FOP of the status of the woomera channel isn't as smooth as expected, and FOP is able to monitor just outgoing calls.

Anyway, at this point it isn't so important, but it would be nice to heard about other people experiences regarding FOP & woomera. Anyone?

Best regards,

--
Txema
 

asteriskpbx

Joined
Oct 2, 2009
Messages
2
Likes
0
Points
0
#4
I have the same problem. Did you solve it?
 

txema

Joined
Jun 4, 2009
Messages
10
Likes
0
Points
0
#5
Actually, not really. After some experimenting, I only got outgoing calls to work, but not incoming calls, for the CUSTOM type trunk I used to monitor my WOOMERA trunk.
Other than that, no success...

Txema
 

asteriskpbx

Joined
Oct 2, 2009
Messages
2
Likes
0
Points
0
#6
I was able to monitor the incoming calls from PSTN to SIP extension. If a SIP extensions makes a call using Woomera channel, I cannot monitor it. Is it the same situation?
 

dwells

Joined
Sep 29, 2009
Messages
127
Likes
0
Points
0
#7
You may be able to try the regxp approach...

[_WOOMERA/.*] ; regexp to match all WOOMERA channels
Position=(n) or X-Y or X,Y,Z ;(n)single static position or x=starting position y= ending position
Label="All Woomera channels" ; or whatever you want
Context=default ;(or a CUSTOM one)
Extension=-1

You may be able to [WOOMERA/(DID HERE)] to monitor just an inbound call?? Not sure.

I've extensivily played with FOP here in Canada, but only our UK office used Sangoma Woomera, So I don't play with that server too much, but it may work.

I've also managed to fit 217 buttons on one screen to monitor many channels/IP's/CID's/Queues etc at once.
You can change the context, reload the server and call it by using

"https://your server/panel/index_amp.php?context=yourCUSTOMcontext"

As a last thought, woomera should use SIP(i think/maybe ZAP) but try the regxp approach to match all three and see which on picks it up!?? Worth a shot I guess.

(restart FOP by: "amportal restart_fop" <enter>) then you don't disrupt anything else.

Hope that helps...
-dwells
 

dwells

Joined
Sep 29, 2009
Messages
127
Likes
0
Points
0
#8
Sorry, you could also try

[localhost/42420]
or
[_localhost/.*] ; regxp approach

this is the deafult Woomera:port settings in woomera.conf.

-dwellsy
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,942
Messages
130,964
Members
17,638
Latest member
washingtongomez
Top