How to define Dahdi Channels in Inbound Routes ?

blackwoodie

Joined
Sep 2, 2008
Messages
23
Likes
0
Points
0
#1
Hi everybody !!

I just install a new Elastix box with the 1.5.2-2 version. This is the first time I use the dahdi upgrade so I got this problem..

I don`t have any SIP provider only PSTN and a GSM Card Bank (For calling CellPhones)in two dahdi channels (Span # 1: WCTDM/4 "Wildcard TDM400P REV E/F Board 5" (MASTER)), on previous versions of Elastix I can define the channel to use in the Inbound Routes but in this version I don`t know how to do it, when I try to add the second Inbound Route (This route will be used to call from Cell-user to Cell-GSM-Base then an extension) elastix says "A route for this DID/CID already exists! => /" and nothing happens..:blush:
Can somebody explainme how to define wich channel the inbound routes will use, or what to do in this version to get this work.

Thanks
Blackwoodie
 

Lou1z

Joined
Aug 20, 2008
Messages
57
Likes
0
Points
0
#2
this ain't gonna help but i've got exactly the same issue with trying to route dahdi to a fax. it's certainly a routing issue as the fax is working. there are a few others on here with the same symptoms. mine occured after an upgrade from 1.3.2 to 1.5.2.
 

DaveD

Joined
Nov 12, 2007
Messages
597
Likes
0
Points
16
#3
I will try to explain

Use un embedded freepbx
under inbound call control set your DID and ZAP channel in Zap channel DID's ,this allows extra DID routes on the 1 zap channel if your telco has it enabled
when done go to inbound routes and create inbound putting in your DID and give it a name
Now there are a few files to change to allow routes on zaptel/dahdi
/etc/asterisk change chan_dahdi.conf to read from-zaptel
next file is
/etc/asterisk change dahdi-channels.conf to read from-zaptel instead of from-pstn

This is how mine is setup and works fine
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,981
Messages
131,060
Members
17,704
Latest member
Pahntom
Top