how to conf trunk using freetalk.com asVOIP SP

Discussion in 'General' started by Ronald, Jun 14, 2010.

  1. Ronald

    Joined:
    Jun 14, 2010
    Messages:
    1
    Likes Received:
    0
    Dear All,
    i have setup my asterisk server and configure extension. locally between ext i we can call others. but i cant make outside calls i.e. international.
    below is my SIP trunk configuration.

    >>TRUNK NAME: Testing
    >>PEER DETAILS:
    ---------------
    host=sip01.us.overvoip.net
    username= account number
    secret=Password
    type=peer
    port=5060
    fromuser=account number
    dtmfmode=rfc2833
    nat=auto
    insecure=very
    disallow=all
    allow=g729
    --------------------------
    USER CONTEXT: account number
    USER DETAILS:
    --------------------
    secret=password
    type=user
    context=from-trunk
    ----------------------
    REGISTER STRING:
    account number:password@sip01.us.overvoip.net/account number

    troubleshooting:
    when i go to asterisk info > SIP registry i get this:

    Host Username Refresh State Reg.Time
    sip01.us.overvoip.net:5060 account_number 120 Request Sent

    PLEASE ADVISE WHERE AM I GOING WRONG.. :(
     
  2. voipbuddy

    Joined:
    Jun 1, 2010
    Messages:
    13
    Likes Received:
    0
    Your problem is sip account is not getting registered, you can try below solutions, dont forget to try pinging your sip provider ip address from your server.


    create a new trunk use this settings
    199.127.47.54 overvoip ip address.

    type=friend
    username=XXXXXXXXX (account id/name)
    fromuser=XXXXXXXXX (account id/name)
    secret=XXXXXX (Password)
    host=199.127.47.54
    fromdomain=199.127.47.54
    dtmfmode=rfc2833
    canreinvite=no
    allow=all

    remove everything from user context

    and go to last line and change it as

    acc-number:password@sip01.us.overvoip.net

    -----------------now in extensions-------------
    go to allow and make is all [allow=all], leave disallow blank.
     

Share This Page