How to Change HTTP Port?

Discussion in 'General' started by RizSher, Jun 9, 2007.

  1. RizSher

    Joined:
    Jun 9, 2007
    Messages:
    13
    Likes Received:
    0
    Before switching to Elastix, I used to do the following to change the http port to access the webserver:

    nano /etc/httpd/conf/httpd.conf

    and in there, change "Listen 80" to "Listen 8888" or whatever port I would like to change it to.

    I've tried the same with Elastix, done /etc/rc.d/init.d/httpd restart, even rebooted, but the port setting still hasn't changed.

    Is there port assignment done somewhere else?.
     
  2. RizSher

    Joined:
    Jun 9, 2007
    Messages:
    13
    Likes Received:
    0
    Got it the long way... installed Webmin... then.. Servers... Apache server...Global settings and changed the port there.
     
  3. adminad

    Joined:
    Apr 29, 2010
    Messages:
    150
    Likes Received:
    0
    Please keep in mind that Elastix redirects the 80 port to the 443 (ssl).
     
  4. RizSher

    Joined:
    Jun 9, 2007
    Messages:
    13
    Likes Received:
    0
    Maybe thats why I can't access the server from my office. Get the following message:

    Seem like https access is blocked from my office, though I can access my online banking, hotmail etc w/o a problem. Is there anything I can do to regain access from work?
     
  5. jr_oblika

    Joined:
    Mar 16, 2007
    Messages:
    67
    Likes Received:
    0
    Some ISP block all port to 1024, so you must change the port of elastix, or forward port on firewall from 80 (443)--> 8080 (8443) (or something).
     
  6. RizSher

    Joined:
    Jun 9, 2007
    Messages:
    13
    Likes Received:
    0
    I have already changed the webserver port to 8812, have also forwarded port 8812 to the ip of the Elastix server from my router's port forwarding screen. At home, I access Elastix by going to httpS://192.168.1.110:8812 (http doesn't work). At work, when i had the same settings with trxbox, I could access the freepbx interface and call logs by goign to http://my.dyndns.domain:8812, now with Elastix, I get the message I pasted in the last post.
     

Share This Page