How to activate WOL?

Discussion in 'General' started by Patrick_elx, Aug 24, 2010.

  1. Patrick_elx

    Joined:
    Dec 14, 2008
    Messages:
    1,120
    Likes Received:
    0
    Maybe a little bit out of topic, but I need to be able to use a wake on lan on my elastix server (when my UPS has only a minute of power left, I'm forcing a shutdown, but my server bios does not know how to start automatically when the power is back).

    My bios has the wol enabled, and I'm trying to set the
    ethtool -s eth0 wol g
    but I have that answer:
    Cannot set new wake-on-lan settings: Operation not supported not setting wol

    however my card seems to support the wol
    Settings for eth0:
    Supported ports: [ TP ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Advertised auto-negotiation: Yes
    Speed: 100Mb/s
    Duplex: Full
    Port: Twisted Pair
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: umbg
    Wake-on: d
    Current message level: 0x00000007 (7)
    Link detected: yes


    My card:
    01:05.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 02)

    Any ideas for a linux dumb like me to make it work?
     
  2. Patrick_elx

    Joined:
    Dec 14, 2008
    Messages:
    1,120
    Likes Received:
    0
    Seems that updating the intel driver for the eth card solved my issue.

    now the ethtool -s eth0 wol g is working.
     

Share This Page