How to activate G722 audio codec

Discussion in 'General' started by michael_zurich, Sep 20, 2008.

  1. michael_zurich

    Joined:
    Apr 2, 2008
    Messages:
    2
    Likes Received:
    0
    Hi

    How to activate G722 audio codec on elastix 1.2.4?

    My elastix 1.2.4 shows with asterisk-cli "core show codecs" that G722 audio codec is there but when I try to make a G722 call there is no G722 in INVITE.

    I use phoner which has G722 as first codec.

    with Elastix I get no G722:
    11:04:33,515: R: 192.168.1.96:5060 (UDP)
    INVITE sip:706@192.168.1.67:5060 SIP/2.0
    Via: SIP/2.0/UDP 192.168.1.96:5060;branch=z9hG4bK60f025e2;rport
    From: "705" <sip:705@192.168.1.96>;tag=as0250a8ca
    To: <sip:706@192.168.1.67:5060>
    Contact: <sip:705@192.168.1.96>
    Call-ID: 4c0ee98401284f452f079e88446f146e@192.168.1.96
    CSeq: 102 INVITE
    User-Agent: Asterisk PBX
    Max-Forwards: 70
    Date: Sat, 20 Sep 2008 09:05:30 GMT
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
    Supported: replaces
    Content-Type: application/sdp
    Content-Length: 264

    v=0
    o=root 20547 20547 IN IP4 192.168.1.96
    s=session
    c=IN IP4 192.168.1.96
    t=0 0
    m=audio 16310 RTP/AVP 0 8 101
    a=rtpmap:0 PCMU/8000
    a=rtpmap:8 PCMA/8000
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-16
    a=silenceSupp:eek:ff - - - -
    a=ptime:20
    a=sendrecv

    with LANCOM I have G722 working
    11:08:44,968: R: 192.168.1.10:5060 (UDP)
    INVITE sip:706@voiplan2.intern SIP/2.0
    Via: SIP/2.0/UDP 192.168.1.10:5060;branch=z9hG4bK-bb3b3a90-8b04d1e2
    From: "705"<sip:705@192.168.1.10;user=phone>;tag=-95254290-584128084
    To: <sip:706@voiplan2.intern;user=phone>
    Call-ID: 3259275999@00a05711fb86
    CSeq: 1 INVITE
    Max-Forwards: 70
    User-Agent: LANCOM 1724 VoIP (Annex B) / 7.56.0046 / 20.08.2008
    Server: lancom2
    Allow: REGISTER, INVITE, ACK, CANCEL, BYE, REFER, NOTIFY, OPTIONS
    Contact: <sip:705@192.168.1.10:5060>
    Content-Type: application/sdp
    Content-Length: 472

    v=0
    o=- 2358955599 2358955599 IN IP4 192.168.1.10
    s=call
    c=IN IP4 192.168.1.10
    t=0 0
    m=audio 52146 RTP/AVP 9 8 0 99 3 18 4 101
    a=rtpmap:9 G722/8000
    a=rtpmap:8 PCMA/8000
    a=rtpmap:0 PCMU/8000
    a=rtpmap:99 G726-32/8000
    a=rtpmap:3 GSM/8000
    a=rtpmap:18 G729/8000
    a=rtpmap:4 G723/8000
    a=rtpmap:101 telephone-event/8000
    a=fmtp:18 annexb=no
    a=fmtp:101 0-16
    a=sendrecv
    a=ptime:20

    Michael
     
  2. michael_zurich

    Joined:
    Apr 2, 2008
    Messages:
    2
    Likes Received:
    0
    I added in sip.conf in the section
    [general]
    allow=g722
    but this does not help.

    Any idea?
    Michael
     
  3. syadnom

    Joined:
    Aug 4, 2009
    Messages:
    36
    Likes Received:
    0
    asterisk 1.4 only does g.722 pass through. you need to patch asterisk to get g.722 translating.

    you should be able to call between two g.722 compatible devices but you wont be able to call voicemail, or non g.722 devices, or place outgoing calls to PSTN or a voip provider that doesnt support g.722
     

Share This Page