How do I avoid the ANSWER() over the line?

Discussion in 'General' started by jvegaseg, Nov 12, 2009.

  1. jvegaseg

    Joined:
    Nov 11, 2009
    Messages:
    3
    Likes Received:
    0
    I had an installation test with Asterisk and everything worked correctly, and I am now trying to replicate the same installation with Elastix 1.6 but I have the problem that automatically issues a Answer() over the line automatically.

    How do I prevent the ANSWER() on the line until an extension is picked-up?

    My testing installation is as follows:

    -I have a OpenVox400P card connected to the telephone line with an analog extension.
    -I have multiple SIP extensions connected to Elastix.
    -I have a ring group to when enters a call sound all extensions (the SIP extensions and analog extension connected to the OpenVox card).
    -On the same phone line I also other connected analog phones.

    Functionality that interests me get is as follows:

    -When you enter a call, sound analog phones, all SIP extensions and analog extension attached to the OpenVox
    -When any phones or extensions calls pick-up the call and stops ringing like the rest of extensions/analog phones

    This worked me well with Asterisk without Elastix because simply did a DIAL to all extensions before you make an ANSWER. The problem is that now Elastix makes first a ANWER and then a DIAL causing analog phones to stop sound without that no one has picked up the call.

    The PAUSE BEFORE ANSWER parameter is useless for me because it causes than first ring analog phones then extensions connected to Elastix and what interests me is that to sound all at once.


    Could someone help me?

    Thanks a lot

    Sorry about my poor English.
     

Share This Page