How can i record the calls in Elastix

wallcrawler

Joined
Oct 1, 2009
Messages
10
Likes
0
Points
0
#1
Hello all,

I´m such a newbie in elastix, and i can´t configure the elastix pbx (FreePbx) to record all incomming and/or outcomming calls. There´s any "How-To" who teachs how to do it?

Thanks.

Wall
 

dwells

Joined
Sep 29, 2009
Messages
127
Likes
0
Points
0
#2
There are different ways to record within the system.

Either set the Always Record option per user account, in the drop down menu when you create/edit an account,

or you can set the 'W' and/or 'w' settings (for Caller/Callee) in General Settings to enable the '*1' function for the On-Demand recording options per channel. In short during a phone call you can press '*1' to start recording. This is saved within the system.

Make sure that in general settings the Record Override is set to Disabled.
These settings do not affect the conference recording options.

If you are using a softphone like X-Lite, you can press the record button, and it will save a wav file in you MyDocs.

Be sure to warn your callers that you are recording/monitoring for Quality purposes, there are built in recordings for this. (just in case)

-dwellsy
 

wallcrawler

Joined
Oct 1, 2009
Messages
10
Likes
0
Points
0
#3
Thanks dwells.

I´ve already do this, but i didn´t see in any folder of elastix the recording calls. Neither in any reports on freepbx or in the elastix administrator.

In which folder this calls is placed when recorded?

Wall.
 

dwells

Joined
Sep 29, 2009
Messages
127
Likes
0
Points
0
#4
try /var/spool/asterisk/monitor for system recorded calls.

-dwellsy
 

wallcrawler

Joined
Oct 1, 2009
Messages
10
Likes
0
Points
0
#5
There´s nothing in this folder. I´ve check all configuration for any mistakes, but everything is exactly what you´ve told me.

Wall.
 

dwells

Joined
Sep 29, 2009
Messages
127
Likes
0
Points
0
#6
Hmm, strange.

Let's try something, edit the extension you are using from PBX tab. Scroll down until you come to the recording section. Flip the incomming and outgoing option to "Always". save and reload.

Call a cell phone/land line or other phone you have control of, either answer it or let it go to voicemail. leave a short message. Check this folder again. (if using WinSCP be sure to refresh folder view) as it will cache the last results.

you should see a file starting with auto-(junk)
as an example here is a file name (in my monitor folder from my 1000 extension) by doing something similar to as mentioned...
auto-1253887022-1000-DID.wav //EDIT i think auto is the On-Demand '*1' option.

this says record from: auto-(UTC code)-EXTEN-DID.wav

If nothing still, there maybe a different setup or config problem...

//EDIT
Sorry I just did this EXACTLY, and this file showed up as
OUT1000-20091002-124820-1254502100.8189.wav when calling myself.
-the folder mentioned above is correct.


-dwells
 

wallcrawler

Joined
Oct 1, 2009
Messages
10
Likes
0
Points
0
#7
i did this but nothing is in monitor folder (folder or anything else).
 

dwells

Joined
Sep 29, 2009
Messages
127
Likes
0
Points
0
#8
Ok, can you give us some CLI output when you make a call from the extension that is set to ALWAYS record please, that might reveal the problem. please make sure that the verbosity is 3 or more, or turn debuging on.

asterisk -vvvvr

thanks
-dwellsy
 

wallcrawler

Joined
Oct 1, 2009
Messages
10
Likes
0
Points
0
#9
I don´t know how to do this, but executing the command above, the response was:

Asterisk 1.4.24, Copyright (C) 1999 - 2008 Digium, Inc. and others.
Created by Mark Spencer <markster@digium.com>
Asterisk comes with ABSOLUTELY NO WARRANTY; type 'core show warranty' for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type 'core show license' for details.
=========================================================================
== Parsing '/etc/asterisk/asterisk.conf': Found
== Parsing '/etc/asterisk/extconfig.conf': Found
Connected to Asterisk 1.4.24 currently running on elastix (pid = 3280)
Verbosity is at least 3

Thanks
Wall
 

dwells

Joined
Sep 29, 2009
Messages
127
Likes
0
Points
0
#10
Hey Wall,

Yup almost there, that command is to open the asterisk console. This is a live view of what the server is writting into the logs anyways, it was to save you from looking through full log files.

When you open this console, make a call...what the code fly. When finished you can use your mouse and select that call information can <Ctrl><C> (copy) and paste it into a notepad for example. (Ctrl+C will also kick out out of the console, but it copies.)

I'm looking for how the call gets setup, it usually does a check to see if this call should be recorded, if it's enable properly. It shouls also give a file name that we could potentially search for in your computer.

Try the LOCATE command.

If we can get some output, I might be able to give you better input.
Thanks
-dwellsy
 

titus

Joined
Oct 15, 2009
Messages
2
Likes
0
Points
0
#11
Hey I have same problem, with same symptoms in every comma.
It looks like the .ISO missed that part, no recording is ever done.
Probably the same old story of Uniq ID that we have to add manually and recompile the mysql.
Does anyone can guide through that?
any help is appreciated..
 

wallcrawler

Joined
Oct 1, 2009
Messages
10
Likes
0
Points
0
#12
Anyone can help us with that?
 

witekprytek

Joined
Dec 19, 2007
Messages
145
Likes
0
Points
0
#13
wallcrawler said:
Anyone can help us with that?
I have the same problem with calls monitoring/recording in Elastix 1.5.2-2.

I have found in configuration file: features_featuremap_additional.conf
something like this:
blindxfer=##
atxfer=*2
automon=*1
disconnect=**

but there is nothing else in other configuration files regarding automon.
I have options Ww for incoming and outgoing calls, but after pressing *1 during calls, nothing happens.

It is no information in system console about any action.
DTMF works fine I can login to remote services via remote IVR.

Does anybody could confirm for sure that recording functions (by pressing *1) works on elastix 1.5.2-2 or does not?


WP
 

charlesrg

Joined
Apr 17, 2009
Messages
17
Likes
0
Points
0
#14
Same issue here. *1 does not work.

ALWAYS Record works, but Record on Demand does not.
 

Bob

Joined
Nov 4, 2007
Messages
2,400
Likes
1
Points
36
#15
Works fine on this end....

Couple of lines from the CLI from extension 201 to extension 202

-- SIP/202-088dd050 answered SIP/201-088d9030
-- User hit '*1' to record call. filename: wav|auto-1256169469-201-202|m

Use this extension to extension as a test first...

Just as a thought, what IP Phones are you using, is it intercepting the *1 command, thinking it is one of its own?? With the Linksys phones, it is necessary to remove all the * commands from the setup, so that it does not intercept the command.

Regards

Bob
 

charlesrg

Joined
Apr 17, 2009
Messages
17
Likes
0
Points
0
#16
Cisco 7940

It could be the phone intercepting, but the DTMF should come to the Asterisk. Do you know if is there any parameters to disable Phone DTMF interception ?

I cannot change the *1 to anything else. The feature code screen does not allow that.
 

charlesrg

Joined
Apr 17, 2009
Messages
17
Likes
0
Points
0
#17
Not a phone problem I just added wW in Asterisk Dial command options:

And that works fine.

The issue is that the End user can Start or Stop the Recording too.

I want only my extension to Start or Stop not the person in the other side of the line.
 

dwells

Joined
Sep 29, 2009
Messages
127
Likes
0
Points
0
#18
You need to watch the W vs. w don't put BOTH in ONE box.

put the 'w' in the Dial box (top one)
put the 'W' in the outbound box (bottom one)

hover your mouse over the title to read the difference between letting the "callee" vs "caller" record the conversation.
 

wallcrawler

Joined
Oct 1, 2009
Messages
10
Likes
0
Points
0
#19
Ok. I´ll test. But i want to record ALL calls, and not let the operador to do this.
 

witekprytek

Joined
Dec 19, 2007
Messages
145
Likes
0
Points
0
#20
Bob said:
Works fine on this end....

Couple of lines from the CLI from extension 201 to extension 202

-- SIP/202-088dd050 answered SIP/201-088d9030
-- User hit '*1' to record call. filename: wav|auto-1256169469-201-202|m

Use this extension to extension as a test first...

Just as a thought, what IP Phones are you using, is it intercepting the *1 command, thinking it is one of its own?? With the Linksys phones, it is necessary to remove all the * commands from the setup, so that it does not intercept the command.

Regards

Bob
Bob,
What codec and DTMF setting do you use?
Does it works for you for incoming/outgoing calls from/to SIP trunk?


Regards
WP
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,886
Members
17,563
Latest member
dineshr
Top