Hold music

Joined
Jan 14, 2009
Messages
34
Points
0
How can I disable the hold music while waiting for the autodialer to connect? It's driving my operators nuts. I found the wav files for the music. I renamed them all to .old but the music is still playing.
 
Joined
Oct 24, 2008
Messages
4,099
Points
0
I believe the contents of the the directory you specified is played with no regard to the file extension.

You could play silence to the agents (upload a file of silence, delete the rest), but this "music" would be also be heard (or not heard) by the callers in the queue.

Perhaps an alternative solution can be found by searching these fori for agentlogincallback, but this behavior might not be what you are used to, (agent gets a ring on their phone when the have a call and must answer to handle it, rather than being "online" and hearing a beep)
 
Joined
Jan 14, 2009
Messages
34
Points
0
Ok, so, I copied Marcelo's paloSantoAgentConsole.class.php file into notepad++, saved it as a php file, winscp'd it to my server, replacing the other file, and I get the same error everyone in that thread was initially getting...

"Number Agent already connected with extensiona 999b SIP/999c e '001' (musiconhold is 'default'"

Not only that, but I am getting constant calls to my soft phone from my asterisk trunk number. There is silence and then it hangs up. This does not stop. And it happens if I'm logged in with a different extension than 999. I replaced the file with my backup and it is still happening!

Here is the file I copied from marcelo's, renamed to txt. Any ideas?

EDIT: Jorge in support told me there was a bug where an Agent will get hung up as still logged in. I can see that when I pick up the calls, Agent 999's calls for today increase. Does anyone know how to fix this? I rebooted the server and it's still happening, constant calls to any extension I am logged in with.

http://forum.elastix.org/old_files/paloSantoAgentConsole-111a50931318ec2e1715a27b72702b99.txt
 
Joined
Jan 14, 2009
Messages
34
Points
0
This is what shows up in my CLI when I get an unintended call. The calls only stop if I stop the autodialer...


<------------->
-- Executing [001@default:1] Macro("Local/001@default-6d1a,2", "exten-vm|novm|001") in new stack
-- Executing [s@macro-exten-vm:1] Macro("Local/001@default-6d1a,2", "user-callerid") in new stack
-- Executing [s@macro-user-callerid:1] Set("Local/001@default-6d1a,2", "AMPUSER=14076410843") in new stack
-- Executing [s@macro-user-callerid:2] GotoIf("Local/001@default-6d1a,2", "1?report") in new stack
-- Goto (macro-user-callerid,s,11)
-- Executing [s@macro-user-callerid:11] GotoIf("Local/001@default-6d1a,2", "0?continue") in new stack
-- Executing [s@macro-user-callerid:12] Set("Local/001@default-6d1a,2", "__TTL=63") in new stack
-- Executing [s@macro-user-callerid:13] GotoIf("Local/001@default-6d1a,2", "1?continue") in new stack
-- Goto (macro-user-callerid,s,20)
-- Executing [s@macro-user-callerid:20] NoOp("Local/001@default-6d1a,2", "Using CallerID "" <14076410843>") in new stack
-- Executing [s@macro-exten-vm:2] Set("Local/001@default-6d1a,2", "RingGroupMethod=none") in new stack
-- Executing [s@macro-exten-vm:3] Set("Local/001@default-6d1a,2", "VMBOX=novm") in new stack
-- Executing [s@macro-exten-vm:4] Set("Local/001@default-6d1a,2", "EXTTOCALL=001") in new stack
-- Executing [s@macro-exten-vm:5] Set("Local/001@default-6d1a,2", "CFUEXT=") in new stack
-- Executing [s@macro-exten-vm:6] Set("Local/001@default-6d1a,2", "CFBEXT=") in new stack
-- Executing [s@macro-exten-vm:7] Set("Local/001@default-6d1a,2", "RT=""") in new stack
-- Executing [s@macro-exten-vm:8] Macro("Local/001@default-6d1a,2", "record-enable|001|IN") in new stack
-- Executing [s@macro-record-enable:1] GotoIf("Local/001@default-6d1a,2", "1?check") in new stack
-- Goto (macro-record-enable,s,4)
-- Executing [s@macro-record-enable:4] AGI("Local/001@default-6d1a,2", "recordingcheck|20090120-100347|1232463827.10") in new stack
-- Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck
recordingcheck|20090120-100347|1232463827.10: Inbound recording not enabled
-- AGI Script recordingcheck completed, returning 0
-- Executing [s@macro-record-enable:5] MacroExit("Local/001@default-6d1a,2", "") in new stack
-- Executing [s@macro-exten-vm:9] Macro("Local/001@default-6d1a,2", "dial||tr|001") in new stack
-- Executing [s@macro-dial:1] GotoIf("Local/001@default-6d1a,2", "1?dial") in new stack
-- Goto (macro-dial,s,3)
-- Executing [s@macro-dial:3] AGI("Local/001@default-6d1a,2", "dialparties.agi") in new stack
-- Launched AGI Script /var/lib/asterisk/agi-bin/dialparties.agi
dialparties.agi: Starting New Dialparties.agi
== Parsing '/etc/asterisk/manager.conf': Found
== Parsing '/etc/asterisk/manager_additional.conf': Found
== Parsing '/etc/asterisk/manager_custom.conf': Found
== Manager 'admin' logged on from 127.0.0.1
dialparties.agi: Caller ID name is 'unknown' number is '14076410843'
dialparties.agi: USE_CONFIRMATION: 'FALSE'
dialparties.agi: RINGGROUP_INDEX: ''
dialparties.agi: Methodology of ring is 'none'
-- dialparties.agi: Added extension 001 to extension map
-- dialparties.agi: Extension 001 cf is disabled
-- dialparties.agi: Extension 001 do not disturb is disabled
> dialparties.agi: extnum 001 has: cw: 0; hascfb: 0 [] hascfu: 0 []
> dialparties.agi: ExtensionState: 0
dialparties.agi: Extension 001 has ExtensionState: 0
-- dialparties.agi: Checking CW and CFB status for extension 001
-- dialparties.agi: dbset CALLTRACE/001 to 14076410843
-- dialparties.agi: Filtered ARG3: 001
> dialparties.agi: NODEST: 0001 adding M(auto-blkvm) to dialopts: trM(auto-blkvm)
> dialparties.agi: NODEST: 0001 blkvm enabled macro already in dialopts: trM(auto-blkvm)
== Manager 'admin' logged off from 127.0.0.1
-- AGI Script dialparties.agi completed, returning 0
-- Executing [s@macro-dial:7] Dial("Local/001@default-6d1a,2", "SIP/001||trM(auto-blkvm)") in new stack
Audio is at 71.43.181.50 port 17508
Adding codec 0x4 (ulaw) to SDP
Adding codec 0x8 (alaw) to SDP
Adding non-codec 0x1 (telephone-event) to SDP
Reliably Transmitting (NAT) to 70.118.98.133:31072:
INVITE sip:001@70.118.98.133:31072;rinstance=2e8f96392bda0af1 SIP/2.0
Via: SIP/2.0/UDP 71.43.181.50:5060;branch=z9hG4bK41a6af72;rport
From: "14076410843" <sip:14076410843@71.43.181.50>;tag=as408090b6
To: <sip:001@70.118.98.133:31072;rinstance=2e8f96392bda0af1>
Contact: <sip:14076410843@71.43.181.50>
Call-ID: 515243553a2f29ff506ffa67599361b2@71.43.181.50
CSeq: 102 INVITE
User-Agent: Asterisk PBX
Max-Forwards: 70
Date: Tue, 20 Jan 2009 15:03:47 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces
Content-Type: application/sdp
Content-Length: 262
 
Joined
Jan 14, 2009
Messages
34
Points
0
Also, I still cannot login with any agents now. I get "Number Agent already connected with extension SIP/002"

I have double checked that my original php file was restored. This has broken my call center and I am freaking out.
 

Members online

No members online now.

Forum statistics

Threads
30,992
Messages
131,106
Members
17,716
Latest member
Orbit114
Top