Help: I've mucked up my Email system, now no email

Discussion in 'General' started by BodleyTunes, Dec 18, 2009.

  1. BodleyTunes

    Joined:
    Dec 18, 2009
    Messages:
    5
    Likes Received:
    0
    Hi,

    I've been trying to setup voicemail to email.

    Yesterday, when I first set elastix up, I left some voicemails and never saw any emails in my mailbox at GOOGLEMAIL.

    I then, without checking properly, went and ran the script that sets elastix to relay email via GMAIL.

    I tried it and still nothing.

    Then to my HORROR I noticed that elastix HAD CORRECTLY been sending email in the first case, but Gmail had put it into the SPAM folder!!!!

    Unfortunately I have done something now, by running the gmail relay script, that stops it from sending altogehter, as at least before I ran the script it did actually send it it. ( I can always mark it as not spam ).

    How do I revert whatever changes that script has done!? as now nothing works :(

    Cheers!

    Jonathan.
     
  2. BodleyTunes

    Joined:
    Dec 18, 2009
    Messages:
    5
    Likes Received:
    0
    Restored the backups of main.cf and generic and restarted the postfix service and still nothing? :(
     
  3. BodleyTunes

    Joined:
    Dec 18, 2009
    Messages:
    5
    Likes Received:
    0
    OK doesnt even seem to be trying to send emails at the moment?


    Dec 18 11:53:53 elastix imap[2543]: executed
    Dec 18 11:53:53 elastix pop3[2544]: executed
    Dec 18 12:07:06 elastix imap[2468]: accepted connection
    Dec 18 12:07:06 elastix master[3020]: about to exec /usr/lib/cyrus-imapd/imapd
    Dec 18 12:07:06 elastix imap[3020]: executed
    Dec 18 12:07:06 elastix imap[2468]: login: localhost.localdomain [127.0.0.1] cy$
    Dec 18 12:07:21 elastix imap[2474]: accepted connection
    Dec 18 12:07:21 elastix imap[2474]: badlogin: localhost.localdomain [127.0.0.1]$
    Dec 18 12:07:56 elastix imap[2541]: accepted connection
    Dec 18 12:07:56 elastix imap[2541]: badlogin: localhost.localdomain [127.0.0.1]$
    Dec 18 12:08:06 elastix master[2445]: process 2468 exited, status 0
    Dec 18 12:08:24 elastix master[2445]: process 2474 exited, status 0
    Dec 18 12:08:24 elastix master[3060]: about to exec /usr/lib/cyrus-imapd/imapd
    Dec 18 12:08:24 elastix imap[3060]: executed
    Dec 18 12:08:59 elastix master[2445]: process 2541 exited, status 0
    Dec 18 12:08:59 elastix master[3080]: about to exec /usr/lib/cyrus-imapd/imapd
    Dec 18 12:08:59 elastix imap[3080]: executed

    0.0.1] plaintext jon.supercamper.co.uk SASL(-13): user not found: checkpass fa$
     
  4. BodleyTunes

    Joined:
    Dec 18, 2009
    Messages:
    5
    Likes Received:
    0
    FIXED

    absolute pillock error!

    I had accidently added a ^X at line 79 in my master.cf and saved it (obviously using Vi as I hate it and now have Nano). Postfix wasnt even running!

    What a pratt :(

    Cheers,

    Jon. :) :D
     

Share This Page