HELP!!! Fatal error during yum update

Discussion in 'General' started by bazzilio22, Aug 26, 2010.

  1. bazzilio22

    Joined:
    Jan 19, 2010
    Messages:
    7
    Likes Received:
    0
    Hello

    During last update following error received below. After that through yum nothing is updating. Please help. Thanks in advance.

    Dependencies Resolved

    ================================================================================
    Package Arch Version Repository Size
    ================================================================================
    Updating:
    freePBX noarch 2.5.2-5rc elastix-updates 26 M

    Transaction Summary
    ================================================================================
    Install 0 Package(s)
    Upgrade 1 Package(s)

    Total download size: 26 M
    Is this ok [y/N]: y
    Downloading Packages:
    freePBX-2.5.2-5rc.noarch.rpm | 26 MB 00:05
    Running rpm_check_debug
    Running Transaction Test
    Finished Transaction Test
    Transaction Test Succeeded
    Running Transaction
    FATAL: tried to install FreePBX 2.5.2, but system has FreePBX 2.8.0
    error: %pre(freePBX-2.5.2-5rc.noarch) scriptlet failed, exit status 1
    error: install: %pre scriptlet failed (2), skipping freePBX-2.5.2-5rc

    Updated:
    freePBX.noarch 0:2.5.2-5rc

    Complete!
     
  2. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    Hi bazzilio22,
    This is a known bug from elastix, and very severe in my oppinion. If you update freepbx using module admin, and then you try to do a yum update, you can't. Please take your time to fill a bug in the bugtracker http://bugs.elastix.org, AFAIK nobody has done so until now.
     
  3. bazzilio22

    Joined:
    Jan 19, 2010
    Messages:
    7
    Likes Received:
    0
    Ticket - 0000464
     
  4. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    Good! Thank you!

    Let's see what the developers say about this..
     
  5. gl1176

    Joined:
    Oct 5, 2009
    Messages:
    55
    Likes Received:
    0
    I also had this problem 2 weeks ago while doing a yum update on a production server.

    I luckily had a full server backup before doing so, but was also moving the system, sooner than I hoped, to Elastix 2.0 from scratch.

    For now, the temporary thing when doing a yum update is to exclude the freePBX package. I added this in my /etc/yum.repos.d/elastix.repo file by adding exclude=freePBX.noarch under each repo.

    You can also add this option at yum update --exclude=freePBX instead of permanently adding it.
     

Share This Page