HELP!! Can't Create E-Mail Account

michael880308

Joined
Mar 22, 2010
Messages
11
Likes
0
Points
0
#1
Hi
I just installed the Elastix 2.0 and try to set up the mail server as I did in 1.6, but when I try to add an account, it tells me an error that " IMAP login error " and won't continue! I activated the email dashboard in the "System" page, it says that "IMAP: Connection Error," seems like the same problem, I run the postfix check command, no error detected.

Also when I try to delete a domain, I clicked the "Delete" button but nothing happens!?

Does anyone has solutions for these? Why can it work in 1.6 but not 2.0?!

Best Regards
Michael Lu
 

geobina

Joined
Jul 4, 2010
Messages
2
Likes
0
Points
0
#2
Same Problem for me elastix 2.0 stable
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#3
Unfortunately Elastix 2.0 (stable) was in fact only considered stable for two days, and even then only by a very few involved, try upgrading to 2.0.1 (which IMHO is still not actually stable), PLEASE file a bug report in the bug-tracker at the bottom of this page, maybe someone will listen, but then again, maybe not :)

regards

dicko
 

vkacisco

Joined
Aug 18, 2010
Messages
3
Likes
0
Points
0
#4
Go to folder /var/www/html/configs edit file email.conf.php - change HOST to 'lo' - it works:)
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#5
And if that works effectively vkacisco , then it remains a bug, please file it and its resolution for the sake of everyone else.

thank you


dicko
 

vkacisco

Joined
Aug 18, 2010
Messages
3
Likes
0
Points
0
#6
Continue of trouble - it create accounts, but i can`t login to imap..Any ideas?
 

vkacisco

Joined
Aug 18, 2010
Messages
3
Likes
0
Points
0
#7
Continue - i changed system name from system to system.ru in Network Network parameters - now i also can`t create account with any interface, and also i can`t login to imap from cyradm. What i need to change in config?
 

dmanghani

Joined
Jul 14, 2009
Messages
83
Likes
0
Points
0
#8
I have been using Elastix 2.0.1 since it was made awaiable. All the modules are working well except the email section. I can use postfix as pop3 & imap bu itself. The webmail module of elastix also works partly ie if i login as user only it works. but a user@abc.com gives imap error. cannot create any account you get imap error:
Maillog reports sucess for login of user, for user@abc.com gives imap: badlogin ....plaintext cyrus SASL(-13) authentication failure check pass failed
Messages gives imap : auxpropfunc error invalid parameter supplied sql_select option missing no mechanism availabe.
 

nick.smith

Joined
Aug 29, 2010
Messages
3
Likes
0
Points
0
#9
I too am experiencing the same issue. Any ideas for a workaround? I tried the ones listed above, but with no luck.
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#10
To my knowledge, it is apparently an ongoing bug in 2.0.? and in MHO a very serious one, to this point in time it is unacknowledged by PaloSanto, there will be no work around until PaloSanto fixes it, please post your concern in the bug-tracker link available below, until you (and everyone else) does, it won't be fixed, the developers just don't come here, you are basically unheard until you add you voice to the many who have this problem. Any bitches and whines are just wasted in these fora, as I have suggested before, nobody from PaloSanto cares to monitor these fora, go figure . . .


(you are not the only one)


(Bob, did you read this (I assume so) ?, you intrinsically put yourself here. . . , but I'm glad you are back ;) your diplomacy is sorely needed)

dicko
 

dmanghani

Joined
Jul 14, 2009
Messages
83
Likes
0
Points
0
#11
I just reinstalled the whole system, started named and presto i could make and delete email accounts, the system is working well since the l0 days
 

Terry

Joined
May 25, 2007
Messages
174
Likes
0
Points
0
#12
even i follw this
Go to folder /var/www/html/configs edit file email.conf.php - change HOST to 'lo'
But still error message on Elastix 2.0.2 ;IMAP login error:
 

Terry

Joined
May 25, 2007
Messages
174
Likes
0
Points
0
#13
even i follw this
Go to folder /var/www/html/configs edit file email.conf.php - change HOST to 'lo'
But still error message on Elastix 2.0.2 ;IMAP login error:
 

Terry

Joined
May 25, 2007
Messages
174
Likes
0
Points
0
#14
even i follw this
Go to folder /var/www/html/configs edit file email.conf.php - change HOST to 'lo'
But still error message on Elastix 2.0.2 ;IMAP login error:
 

Terry

Joined
May 25, 2007
Messages
174
Likes
0
Points
0
#15
even i follw this
Go to folder /var/www/html/configs edit file email.conf.php - change HOST to 'lo'
But still error message on Elastix 2.0.2 ;IMAP login error:
 

morrishong

Joined
Apr 10, 2007
Messages
20
Likes
0
Points
0
#16
i just installed elastix 2.0 and yum updated.
I am having same trouble ...
 

geobina

Joined
Jul 4, 2010
Messages
2
Likes
0
Points
0
#17
Hi all,

After installing a fresh copy of elastix 2.0 i made these changes for my email to work:

1- I change the host name under network parameters to "server1.example.com"
2- From webmin i remove the line "virtdomains: yes" from etc/imapd.conf
3- I create an email domain "example.com" plus the email domain that i am going to use it for example "mydomain.org"
4- I create mailboxes under "mydomain.org" without any errors
5- From webmin i add the line "virtdomains: 1"

So simple, I am using now my email server without any errors from webmail and from Microsoft outlook

Good luck

Geobina
 

Lee Sharp

Joined
Sep 28, 2010
Messages
332
Likes
0
Points
0
#18
Oh, now that is wonderfully intuitive. :) And only requires installing one additional package! I am so glad my e-mail is on another box, as I would still call that a major bug.
 

nick.smith

Joined
Aug 29, 2010
Messages
3
Likes
0
Points
0
#19
After editing /etc/hosts, I was able to resolve this issue.

Below are the contents of my /etc/hosts:

# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 localhost localhost.localdomain
::1 localhost6.localdomain6 localhost6

I have updated the bug tracker as well.
http://bugs.elastix.org/view.php?id=382
 

XChris

Joined
Aug 20, 2009
Messages
5
Likes
0
Points
0
#20
In Elastix 2.0.3 all the problems are still there... Imap Erros + cannot delete domains. I tried everything with no luck. Is this a solved bug, I do not think so. I believe I should go back to 1.5.2 when all worked like charm...
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,886
Members
17,563
Latest member
dineshr
Top