Having many problems in elastix 1.3

Discussion in 'General' started by iratik, Dec 9, 2008.

  1. iratik

    Joined:
    Dec 6, 2008
    Messages:
    4
    Likes Received:
    0
    Got an error when trying to add a new campaign, i think it was parsing the csv file for archivo llamadas, it enters entries into the calls table. There is no dnc column on my call_center.calls table, i added it in and then it worked fine.

    received a blank screen when trying to update the campaign
    looked deep into the modules "callcenter_config" in modules/callcenter_config/libs/paloSantoConfiguration.class.php" in SaveConfiguration.

    Debugged, execution was stopping at this line
    "$bContinuar = $this->_DB->genQuery('DELETE FROM valor_config WHERE config_key = ?', array($dbfield));"

    but there was no errMsg.. I dumped $this->_DB before that line and saw that valor_config did not exist

    Curious as why there were so many references to tables/columns that did not exist,, i greped the new module tgz file for valor_config and found "call_center.sql" ... There are some remote procedures that are not working

    "cat call_center.sql | mysql -u root -pt4r4 call_center
    ERROR 1146 (42S02) at line 330: Table 'mysql.proc' doesn't exist"


    # mysql -u root -pt4r4
    Welcome to the MySQL monitor. Commands end with ; or \g.
    Your MySQL connection id is 10081
    Server version: 5.0.45

    Looked into the code around 330, saw that it was code to remove a column from the agents table and to add the column dnc to the calls table. Removed all that code in the campos_2009_09_08 section, and the sql ran fine.


    Able to login to the console now, but nothing is being dialed as indicated from the CLI. What might be going on now?

    I'm going to be an expert at reading your source code by the time i get one call to go through on the dialer.

    Please help me, I'm not stupid and I will work to help myself as you can see.. but I need some help from the developers , so I can get this working ..! ?
     
  2. iratik

    Joined:
    Dec 6, 2008
    Messages:
    4
    Likes Received:
    0
    So .. calls are not dialing

    Looked for "Originate" in the call center source.
    Found DialerProcess.class.php
    Looked for the corresponding file on my system
    Found it in /opt/elastix/dialer
    Saw many AGI commands there.. especially for originate...
    Modified phpagi-asmanager-elastix.php to just use error_log, also added "$this->log($req) to send_request"
    Saw nothing but this
    "
    Tue, 09 Dec 2008 09:58:45 -0600 - Action: Command
    Command: show queue 4000


    Tue, 09 Dec 2008 09:58:55 -0600 - Action: Command
    Command: agent show


    Tue, 09 Dec 2008 09:58:55 -0600 - Action: Command
    Command: show queue 4000


    Tue, 09 Dec 2008 09:58:59 -0600 - Action: Command
    Command: agent show
    "
    Didn't learn anything significant from the output. Went looking else where for helpful debugging information.
    Saw an applicationlog class.
    Modified the class to output to stdout since there is no documentation on where elastix logs its stuff to.

    "DEBUG: estado actual de campa
     

Share This Page