Hangup detection

Discussion in 'General' started by nachogomez, Oct 31, 2008.

  1. nachogomez

    Joined:
    Sep 11, 2008
    Messages:
    65
    Likes Received:
    0
    Hi everyone,

    I'm having trouble detecting hangups in Elastix 1.3-2.

    I have an Asterisk installation (self made, without FreePBX) which is detecting hangups just fine using the busydetect / busycount options.

    I have replicated the config in my Elastix box but is still not working.

    I have a Sangoma Remora Card A400D (wich I moved from the self made Asterisk to Elastix).

    This is the relevant part of the zapata.conf file of the self made Asterisk:

    [channels]
    context=default
    usecallerid=yes
    hidecallerid=no
    callwaiting=yes
    usecallingpres=yes
    callwaitingcallerid=yes
    threewaycalling=yes
    transfer=yes
    canpark=yes
    cancallforward=yes
    callreturn=yes
    echocancel=yes
    echocancelwhenbridged=yes
    useincomingcalleridonzaptransfer=yes
    relaxdtmf=yes
    rxgain=0.5
    txgain=0.0
    group=0
    callgroup=0
    pickupgroup=1

    callerid="External Call"
    busydetect=yes
    busycount=3
    callprogress=yes
    progzone=us
    hanguponpolarityswitch=yes




    This is the relevant part of the zapata.conf file of the Elastix:

    [channels]
    context=from-pstn
    signalling=fxs_ks
    ;rxwink=300 ; Atlas seems to use long (250ms) winks
    usecallerid=yes
    hidecallerid=no
    callwaiting=yes
    usecallingpres=yes
    callwaitingcallerid=yes
    threewaycalling=yes
    transfer=yes
    canpark=yes
    cancallforward=yes
    callreturn=yes
    echocancel=yes
    echocancelwhenbridged=yes
    faxdetect=incoming
    ;echotraining=800
    rxgain=0.5
    txgain=0.0
    callgroup=1
    pickupgroup=1

    ;Uncomment these lines if you have problems with the disconection of your analog lines
    busydetect=yes
    busycount=3



    These options are in chan_dahdi.conf:

    callprogress=yes
    progzone=us
    hanguponpolarityswitch=yes



    What can I do in order to solve this situation???

    Thanks a lot for any suggestion, bye...

    Nacho
     
  2. saleh

    Joined:
    Apr 18, 2007
    Messages:
    249
    Likes Received:
    0
    Please try to add these lines in your zapata.conf .

    usecallingpres=yes
    callreturn=yes
    busydetect=yes
    busycount=4
    hanguponpolarityswitch=yes
     
  3. nachogomez

    Joined:
    Sep 11, 2008
    Messages:
    65
    Likes Received:
    0
    Hi saleh, thanks for your response... Sadly it still doesn't work, any other ideas???
     

Share This Page