Google Voice, Ooma & Elastix

Lynn Haag

Joined
Feb 21, 2018
Messages
4
Likes
0
Points
1
#1
Hello! First of all, I'd like to thank you for reading about my problem and thank you!

Here is my setup:

I have 2 Ooma accounts with 2 Linx devices, providing a total of 4 pots lines.

Ooma #1, Linx #1 grouped with 1 Phone Number without Call forwarding enabled
Ooma #2, Linx #2 grouped with 1 Phone Number without Call forwarding enabled

With Ooma & Linx I have only 1 primary number, and when you call in, it rings the primary Ooma device and the Linx device at the same time until 1 is answered.

I have a Google Voice number which is my main telephone number.

I enabled google voice to ring to my Ooma 1 primary number, and Ooma 2 primary number. When I had my analog lines, all 4 lines would ring, and the first line to be answered connected and it all worked fine, but I wanted to add some IP phones...

I setup an Elastix with 4 POTS lines, and multiple IP phones.

On the outbound side of things everything is working fine. I am able to make 4 outbound calls without any problems, but when inbound calls hit the system is when I start to get problems.

When Google Voice rings, it rings all lines at once, when this happens, my pbx server is answering the call and disconnecting it with a random message, "We are sorry you are having problems" and hangs up the line.

When I have google voice only ring 1 Ooma system say Ooma #1 and I disconnect the Linx #1 from the PBX, the Elastix passes the call onto the IP phones, and I can answer it just fine. My problem is I cannot tell google voice to only ring 1 phone number until it's busy then ring the next, creating a queue.

What am I doing wrong with the configuration, or what can I do to fix it? I am a network engineer, not a phone guy and I'm pulling my hair out on this one.

Please feel free to ask any additional questions. Thank you so much for your help.

Sincerely,

Lynn
 

AJP

Staff member
Joined
Dec 6, 2016
Messages
303
Likes
19
Points
68
#2
Hello! First of all, I'd like to thank you for reading about my problem and thank you!

Here is my setup:

I have 2 Ooma accounts with 2 Linx devices, providing a total of 4 pots lines.

Ooma #1, Linx #1 grouped with 1 Phone Number without Call forwarding enabled
Ooma #2, Linx #2 grouped with 1 Phone Number without Call forwarding enabled

With Ooma & Linx I have only 1 primary number, and when you call in, it rings the primary Ooma device and the Linx device at the same time until 1 is answered.

I have a Google Voice number which is my main telephone number.

I enabled google voice to ring to my Ooma 1 primary number, and Ooma 2 primary number. When I had my analog lines, all 4 lines would ring, and the first line to be answered connected and it all worked fine, but I wanted to add some IP phones...

I setup an Elastix with 4 POTS lines, and multiple IP phones.

On the outbound side of things everything is working fine. I am able to make 4 outbound calls without any problems, but when inbound calls hit the system is when I start to get problems.

When Google Voice rings, it rings all lines at once, when this happens, my pbx server is answering the call and disconnecting it with a random message, "We are sorry you are having problems" and hangs up the line.

When I have google voice only ring 1 Ooma system say Ooma #1 and I disconnect the Linx #1 from the PBX, the Elastix passes the call onto the IP phones, and I can answer it just fine. My problem is I cannot tell google voice to only ring 1 phone number until it's busy then ring the next, creating a queue.

What am I doing wrong with the configuration, or what can I do to fix it? I am a network engineer, not a phone guy and I'm pulling my hair out on this one.

Please feel free to ask any additional questions. Thank you so much for your help.

Sincerely,

Lynn
Hi Lynn, thanks for contacting, but before I would like to know if you are using Elastix Version 5?

If you are using and old version such as 2.5.or 4, then please feel free to post in the forum specially for those versions.

Thank you so much!
 

Lynn Haag

Joined
Feb 21, 2018
Messages
4
Likes
0
Points
1
#3
I'm sorry for not posting this in the correct area. Here is my version:

Kernel
Linux(x86_64) 3.10.0 229.14.1.el7.x86_64
Elastix
elastix 4.0.0
 

Yeison Camargo

Staff member
Joined
Jan 2, 2017
Messages
22
Likes
1
Points
3
#4
Hello Lynn,

Please note that you are not using Elastix 5 and consequently we cannot help you in this forum. So, you will need to post you request in the specific forum for Elastix 4.
 

Lynn Haag

Joined
Feb 21, 2018
Messages
4
Likes
0
Points
1
#5
Can you direct me to that forum? I will upgrade to version 5 in the meantime.
 

AJP

Staff member
Joined
Dec 6, 2016
Messages
303
Likes
19
Points
68
#6

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,981
Messages
131,060
Members
17,704
Latest member
Pahntom
Top