Getting "the number you have dialed is not in..."

Discussion in 'General' started by medium_grade, Dec 24, 2009.

  1. medium_grade

    Joined:
    Apr 3, 2009
    Messages:
    9
    Likes Received:
    0
    I have setup my trunks, my SIP provider (simplesignal) has verified that the PBX is properly registered. I have setup one inbound route (answers to any/any) which is supposed to terminate to an extension I have setup. Unfortunately, when a call comes in, I get "the number you have dialed is not in service..." error. Below is a dump from my logs:

    Dec 23 17:42:41 VERBOSE [3659] logger.c:
    -- Executing [8185555555@from-sip-external:1] NoOp("SIP/simplesignal-08520e70", "Received incoming SIP connection from unknown peer to 8185555555") in new stack
    Dec 23 17:42:41 VERBOSE [3659] logger.c:
    -- Executing [8185555555@from-sip-external:2] Set("SIP/simplesignal-08520e70", "DID=8185555555") in new stack
    Dec 23 17:42:41 VERBOSE [3659] logger.c:
    -- Executing [8185555555@from-sip-external:3] Goto("SIP/simplesignal-08520e70", "s|1") in new stack
    Dec 23 17:42:41 VERBOSE [3659] logger.c:
    -- Goto (from-sip-external,s,1)
    Dec 23 17:42:41 VERBOSE [3659] logger.c:
    -- Executing [s@from-sip-external:1] GotoIf("SIP/simplesignal-08520e70", "0?from-trunk|8185555555|1") in new stack
    Dec 23 17:42:41 VERBOSE [3659] logger.c:
    -- Executing [s@from-sip-external:2] Set("SIP/simplesignal-08520e70", "TIMEOUT(absolute)=15") in new stack
    Dec 23 17:42:41 VERBOSE [3659] logger.c:
    -- Channel will hangup at 2009-12-24 01:42:56 UTC.
    Dec 23 17:42:41 VERBOSE [3659] logger.c:
    -- Executing [s@from-sip-external:3] Answer("SIP/simplesignal-08520e70", "") in new stack
    Dec 23 17:42:41 VERBOSE [3659] logger.c:
    -- Executing [s@from-sip-external:4] Wait("SIP/simplesignal-08520e70", "2") in new stack
    Dec 23 17:42:43 VERBOSE [3659] logger.c:
    -- Executing [s@from-sip-external:5] Playback("SIP/simplesignal-08520e70", "ss-noservice") in new stack
    Dec 23 17:42:43 VERBOSE [3659] logger.c:
    -- <SIP/simplesignal-08520e70> Playing 'ss-noservice' (language 'en')
    Dec 23 17:42:48 VERBOSE [3659] logger.c:
    -- Executing [s@from-sip-external:6] PlayTones("SIP/simplesignal-08520e70", "congestion") in new stack
    Dec 23 17:42:48 VERBOSE [3659] logger.c:
    -- Executing [s@from-sip-external:7] Congestion("SIP/simplesignal-08520e70", "5") in new stack


    8185555555 is not what's actually in the log, I simply replaced it for security purposes. Can someone help me determine what may be wrong?
     
  2. voya

    Joined:
    Apr 6, 2009
    Messages:
    15
    Likes Received:
    0
    I think theat this is a problem:

    "Received incoming SIP connection from unknown peer to 8185555555" in new stack

    try to set in your trunk settings
    insecure=very
     
  3. medium_grade

    Joined:
    Apr 3, 2009
    Messages:
    9
    Likes Received:
    0
    Re:Getting "the number you have dialed is not in..

    Had done that already.

    What fixed it was changing the context from "from-sip-external" to "from-trunk".
     
  4. voya

    Joined:
    Apr 6, 2009
    Messages:
    15
    Likes Received:
    0
    Re:Getting "the number you have dialed is not in..

    ok thanks for sharing!
     
  5. Razzyel

    Joined:
    Nov 28, 2011
    Messages:
    2
    Likes Received:
    0
    Dear,

    Can you please explain in wich file you change it ? I have the same problem and i can't fix.

    Regards,
     

Share This Page