getting linksys spa921 phones to work with * codes

Discussion in 'IP Phones' started by reynolwi, Jun 22, 2009.

  1. reynolwi

    Joined:
    May 5, 2008
    Messages:
    100
    Likes Received:
    0
    I have a linksys spa921 phone on elastix 1.5.2-2 and im trying to get the phone to be able to use the feature codes but the phone doesnt like any kind of * codes. Does anyone know how to get around this and get the phone to accept them?
     
  2. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    you need *xx as one of the pattern matches in your dial string, either on the linksys web page or in the tftpboot/ file if you are provisioning them with Elastix. You might need to disable the "vertical service activation codes" in the phones if they collide with asterisk codes, your dtmf signaling should be "auto"
     
  3. reynolwi

    Joined:
    May 5, 2008
    Messages:
    100
    Likes Received:
    0
    this is my dial plan on the linksys phone and it already has that in the dial plan but i guess its not working.

    (*xx|[3469]11|0|00|[2-9]xxxxxx|1xxx[2-9]xxxxxxS0|xxxxxxxxxxxx.)
     
  4. mihpel

    Joined:
    May 8, 2007
    Messages:
    87
    Likes Received:
    0
    This is what i've been using on a couple of linksys ata to get them to work with feature codes.
    Compare it to yours to spot the difference

    Code:
    (xx.|*xx.|**xx.|[3469]11|0|00|[2-9]xxxxxx|1xxx[2-9]xxxxxxS0|xxxxxxxxxxxx.)
    ps: It's one line but i can't get it not to wrap.
     
  5. reynolwi

    Joined:
    May 5, 2008
    Messages:
    100
    Likes Received:
    0
    that worked perfectly. now the phone can dial feature codes without getting the fast busy signal. interesting how you would think just the *xx would work.
     

Share This Page