freepbx translate bug

pnaves

Joined
May 27, 2009
Messages
66
Likes
0
Points
0
#1
Hi, Folks,

I'm currently translating all elastix to Portuguese-BR but embedded freepbx seems have a bug preventing the translate succeed, even that the unembedded freepbx be totally translated. Anyone knows how I could proceed this translate?


Best Regards,
Pedro
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#2
Hi.

Into each modules (/var/www/html/admin/), there's a i18n folder and this folder content any folder for each language. Into this language folder you have a LC_MESSAGES folder with 2 files:
module_name.mo and .po
You can modified this .po file.

(The .mo is a compiled version).
 

pnaves

Joined
May 27, 2009
Messages
66
Likes
0
Points
0
#3
Thank you for reply!

The freepbx modules is already translated but when I access the freepbx modules inside elastix the translation isn't applied. I read somewhere in this forum that there is a bug causing this behavior. Even when I selected Spanish the freepbx content remains in english.

Regards,
Pedro
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#4
ok, 2 ways:
  • Add some words into: /var/www/html/lang/*.lang (* your language file)
    Add some words into: /var/www/html/modules/the_module/lang/*.lang

In my case, I did make all translation like that! ;)

Regards
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#5
oups,I forgot.

The first way it's generally used for the menu.
The second way is used for the module.
 

daMMned

Joined
Nov 25, 2009
Messages
2
Likes
0
Points
0
#6
I have a some problem.

I'm using Elastix version 1.5.2. My local settings is Russian, but some content is not Russian.
For example - Extensions - in Elatix (ip - 192.168.1.20) is English, but in FreeBPX (192.168.1.20/admin/) Extension module is Russian.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,915
Messages
130,920
Members
17,595
Latest member
feparra121
Top