Freepbx 2.9

Discussion in 'General' started by tpsretard, Feb 28, 2011.

  1. tpsretard

    Joined:
    Feb 28, 2011
    Messages:
    1
    Likes Received:
    0
    I tried the FreePBX 2.9 bata.

    It is really nice. wonderful features,
    however it had one small problem.

    When i installed it, it broke the elastics page.

    When i try and go to the main elastix login page, i get a blank screen.
    When i check the apache error log i get.

    PHP Fatal error: Call to a member function getAll() on a non-object in /var/www/html/admin/libraries/freepbx_conf.class.php on line 215

    is there an easy way to fix this, or downgrade the FreePBX back to 2.8
     
  2. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    dont even try join the club using freed from jail freepbx...elastix freepbx embedded is crap and brokes everything..so get down with it and test the beta!!!!
     
  3. GreatSUN

    Joined:
    Mar 6, 2011
    Messages:
    10
    Likes Received:
    0
    I got rid of these errors with small changes, but I didn't get rid of the $db->getAll() error. Seams there is some change in querying the database from freePBX 2.8 to 2.9.

    Just saw that Elastix RC5 supports freePBX 2.9 already. So, I will upgrade Elastix now, too.
     
  4. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Dream on, they are still earnestly working on breaking FreePBX 2.7, FreePBX 2.9 is way out of their league as yet.
     
  5. GreatSUN

    Joined:
    Mar 6, 2011
    Messages:
    10
    Likes Received:
    0
    Hmmmm... but sip extension add blank page tm1000 said "I fixed the blank page issue in Elastix on the Embedded FreePBX extensions page in RC5 (mirror.freepbx.org/modules/release/2.9/e...ntman-2.9.latest.tgz)."
    Looks like a bit of a difference for me...

    Btw. I am running asterisk 1.8.3 with freePBX 2.9 now cause I need it and if elastix doesn't get a solution for this problem, I will do it myself (if I find the time for it).
     
  6. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    thats the spirit and dont forget to share your test and bug discoveries in freepbx.org forums and bug tracker
     
  7. shakirov

    Joined:
    Dec 20, 2010
    Messages:
    1
    Likes Received:
    0
    is anyone have a fix for elastix?

    after updating freepbx to 2.9.0 ?menu=pbxconfig gives me an error 500

    [09/Mar/2011:21:09:31 +0300] "GET /index.php?menu=pbxconfig HTTP/1.1" 500 -
     
  8. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    Re: Re:Freepbx 2.9

    there is not fix for elastix!!!! as you re not using elastix anymore after upgrades of our own...u need to correct some code that is broken specifically because of freepbx...and by the way because of what u need to use embedded freepbx again????
     
  9. GreatSUN

    Joined:
    Mar 6, 2011
    Messages:
    10
    Likes Received:
    0
    Because elastix is still better combination and administration environment with lots of easy to handle features which are no standard in freepbx.
     
  10. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    Re: Re:Freepbx 2.9

    what ??? freepbx 2.9 install only breaks the useless embebded pbx page that has no use if u have 2.9 unembedded...what are u talking about?
     
  11. GreatSUN

    Joined:
    Mar 6, 2011
    Messages:
    10
    Likes Received:
    0
    Talking about everything around the pbx-page. Cause at my site everything around is also broken. But that might have to do with the combination of Asterisk 1.8.3 and FreePBX 2.9. Anyways, I need both.
     
  12. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    I don't think so, Elastix can not really claim to distribute pure FreePBX, they have some very old libraries around and some "improvements" that are arguably not , FreePBX 2.9 is really quite different even from 2.8 in the way it parses it's configuration (amportal.conf et al.) to the point that Elastix embedded would need a complete re-rwite or will have to stay at 2.7, if you NEED FreePBX 2.9 , try:

    http://www.asterisk.org/asterisknow/

    both Asterisk 1.8 and FreePBX 2.9 are just a few clicks away

    dicko
     
  13. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    Re: Re:Freepbx 2.9

    impressive as always my friend...
    but i use freepbx 2.9 on astersk 1.8.4.rc (testing environment) over elastix 2.4 beta and only pbx menu is blank and it does not broke anything else as pbx menu does not have any useful menus inside.
     
  14. GreatSUN

    Joined:
    Mar 6, 2011
    Messages:
    10
    Likes Received:
    0
    Nice :eek:)

    I wasn't able to get 1.8.4 working (wasn't loading the modules needed even though they been there).
    and also I was not able to get anything of elastix working with freepbx 2.9 and asterisk 1.8.3. But anyways, I am able to work and I dont have too many problems with not having the other menues from elastix.
     
  15. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    Re: Re:Freepbx 2.9

    then its really odd...
     
  16. GreatSUN

    Joined:
    Mar 6, 2011
    Messages:
    10
    Likes Received:
    0
    you're right, but I don't have the time to find out why this happened right now.
    I will check out that asap. But with menuselect I checked that selected values have been the same and since I didn't change anything in the configuration, I don't have any further idea than that there is something else wrong...
     
  17. afshin

    Joined:
    Aug 30, 2010
    Messages:
    2
    Likes Received:
    0
    I think this is happen because new structure of amportal.conf.
    in my case first PBX menu looking for php-asmanager.php file after that i put that file
    and receive white page, and none of links working after that.
    i change PBX menu to load /index.php?menu=fop and i can get rid of white page
    and still we need to do not click on PBX Configuration menu the problem exist here.
    the index.php file in /var/www/html/modules/pbxadmin can not comunicate with new amportal.conf i think the page goes to a loop and i can't get any error log there.
    i am working on it. maybe my opinion is wrong if any one has any idea lets share it. thanks.
     
  18. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Largely the source information for may last post in this thread, was from the horses mouth:

    http://www.freepbx.org/news/2011-02-28/ ... m-confused

    After reading that, you will perhaps agree with my summation in that post . . .to the point that Elastix embedded would need a complete re-rwite or will have to stay at 2.7 . . .

    dicko
     
  19. afshin

    Joined:
    Aug 30, 2010
    Messages:
    2
    Likes Received:
    0
    definitely i am agree with you
     
  20. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    Re: Re:Freepbx 2.9

    no to any rewrites...yes to freepbx embebded definitive deletion
     

Share This Page