Free PBX 2.5.0 Beta

Status
Not open for further replies.

rafael

Joined
May 14, 2007
Messages
1,454
Likes
1
Points
0
#1
Dear community,

We just released FreePBX 2.5.0 beta so that you can tested. Do not use this version of freepbx on production Elastix servers is just for testing purpose.

To use this rpm you would need to enable the Elastix Beta repos:

Installation instructions
Add the Elastix-Beta RPM Repository for CentOS:
-Go to the admin web interface
- go to updates
- add extra repositories
Update freepbx
- yum update freepbx

Enjoy
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#2
Ha... Thanks Rafael for this good news.:woohoo:

I thought that before the release there would be the 2.4.1!
But no. :blink:

Cool B)
 

saleh

Joined
Apr 18, 2007
Messages
249
Likes
0
Points
0
#3
The freePBX 2.5.x in itself working fine.
But in embeded freePBX on extension options all fields are empty, its not freePBX problem, its Elastix Embeded freePBX PROBLEM.
 

saleh

Joined
Apr 18, 2007
Messages
249
Likes
0
Points
0
#4
To resolve the problem on embeded freePBX 2.5.x "Problem: on extension options all fields are empty"

# vi /var/www/html/modules/pbxadmin/index.php

and after this line
$GLOBALS['recordings_save_path'] = "/tmp/";

please add this tow lines
$GLOBALS['_guielement_tabindex'] = 1;
$GLOBALS['_guielement_formfields'] = 0;

I hope this fix added in the next version with Free PBX 2.5.x
 

chocho

Joined
Nov 7, 2007
Messages
74
Likes
0
Points
0
#5
WOW, that was good.
Thanks!
 

luetzz

Joined
Mar 1, 2008
Messages
21
Likes
0
Points
0
#6
Saleh!!!

Blessed be you!!!

Thanks very much.

Works in a snap your patch to Elastix x FreePBX 2.5.1
 

Nili

Joined
Nov 15, 2007
Messages
17
Likes
0
Points
0
#7
Thank you Saleh!!:)

I felt already very bad about upgrading to 2.5 beta. Now it's ok.

Pls. can anybody tell me:

The used modules with elastix mostly often not updated over long time and feels old. (Just feeling)


Now my questions regarding upgrading within freepbx:

Which modules should bee upgraded (important for function, fixed bugs, needed for elastix propper work) ??

Which modules might be upgraded (it does not matter to elastix) ??

Which modules should not be upgraded (would disturb the elastix addons) ??

Nili
 

saleh

Joined
Apr 18, 2007
Messages
249
Likes
0
Points
0
#8
Dear Nili,

preferable, all enabled modules to be upgraded.

Please see the shown below steps, which usually used:

Enable/Disable Module via Unembedded FreePBX => Module Admin
Update Module via Unembedded FreePBX => Module Admin => Check for updates online

Best Regards
Saleh Madi
 

Nili

Joined
Nov 15, 2007
Messages
17
Likes
0
Points
0
#9
Thank you Saleh, for your info

I have now upgraded. Everything works fine.

Best Regards

Nili
 

Bob

Joined
Nov 4, 2007
Messages
2,400
Likes
1
Points
36
#10
Sorry Guys it was the wrong area for the post
 
Status
Not open for further replies.

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,887
Members
17,565
Latest member
omarmenichetti
Top