FOP Password Change Causing FreePBX Issues

Discussion in 'General' started by manu3569, Jan 24, 2010.

  1. manu3569

    Joined:
    Jan 24, 2010
    Messages:
    1
    Likes Received:
    0
    Hi experts,

    I've recently installed the latest version of Elastix on a test server, and I'm working on hardening the system, so I'm changing all the default passwords.

    I've noticed that when I change the FOP password in the /etc/amportal.conf file to anything other than 'eLaStIx.2oo7', the following links are disabled in FreePBX:

    -extensions
    -blacklist
    -day/night control
    -follow me

    When I change it back to 'eLaStIx.2oo7' it works again. This seems like very strange behavior. Do I need to change the password somewhere else too?

    Thanks for your help in advance.


    Procedure:
    ==========


    [root@elastix ~]# vi /etc/amportal.conf
    ---> change FOPPASSWORD from 'eLaStIx.2oo7' to 'LaStIx.2oo7'
    [root@elastix ~]# amportal restart



    STOPPING ASTERISK
    Asterisk Stopped

    STOPPING FOP SERVER
    FOP Server Stopped
    SETTING FILE PERMISSIONS
    Asterisk ended with exit status 0
    Asterisk shutdown normally.
    Permissions OK

    STARTING ASTERISK
    Asterisk Started

    STARTING FOP SERVER
    FOP Server Started
     
  2. rafael

    Joined:
    May 14, 2007
    Messages:
    1,454
    Likes Received:
    1
    it looks like a bug. Can you please report this in bugs.elastix.org

    Regaerds,

    Rafael
     

Share This Page