FOP contantly flashing

blackrider

Joined
Aug 12, 2008
Messages
2
Likes
0
Points
0
#1
Hi everyboy,
I just noticed that all the registered extensions and Trunks keeps flashing green/red on the flashing operator panel even though they are registered and working without any issues.
Shouldn`t it be contant green when registered and when no Incoming or Outgoing calls?
Looks like a bug in the new release.
 

DaveD

Joined
Nov 12, 2007
Messages
597
Likes
0
Points
16
#2
The recent release of Adobe Flash Player had caused some grief with the Elastix/FreePBX FOP where all the Trunks, Extensions are flashing Green & Red, here is a script which will resolve this issue.

1. Login to your Elastix Server and at ROOT do the following.
2. Download the flashingfop.tar.gz from here http://www.elastixconnection.com/index. ... &Itemid=72
3. Untar the file you downloaded (tar -xvf flashingfop.tar.gz)
4. Change permission of file flashingfop.sh (chmod 755 flashingfop.sh)
5. Issue the following ./ flashingfop.sh
6. Your Elastix Server FOP will now be restarted automatically.
7. Refresh your web browser cache

As always use this at your own risk.

Thanks to Cleve J for this fix
 

jollyr

Joined
Aug 13, 2008
Messages
2
Likes
0
Points
0
#3
great fix i just follow this and every things works fine..
 

samix4u

Joined
Mar 31, 2008
Messages
20
Likes
0
Points
0
#4
how do i do this please explain "Issue the following ./ flashingfop.sh"
 

DaveD

Joined
Nov 12, 2007
Messages
597
Likes
0
Points
16
#5
At the console or ssh window type ./flashingfop.sh and hit enter and the script will run
 

Newcopia

Joined
Apr 3, 2008
Messages
14
Likes
0
Points
0
#6
OK I am a dummie where do I download the file flashingfop.tar.gz ? does it go in the root directory or some other location?
 

wutthiphan

Joined
Dec 19, 2007
Messages
4
Likes
0
Points
0
#7
I followed the construction but FOP still flashing.

other suggestion?

Thank you.
 

DaveD

Joined
Nov 12, 2007
Messages
597
Likes
0
Points
16
#8
Sorry put the file into root dir
 

jsfix

Joined
Feb 25, 2008
Messages
18
Likes
0
Points
0
#9
Easy Instruccions to Resolve Flash Operator Panel. Flashing

# cd /usr/src
# mkdir test
# cd test
# wget http://freewebs.com/jsfixcc/flashingfop.tar.gz
# tar -xvf flashingfop.tar.gz
# chmod 755 flashingfop.sh
# ./ flashingfop.sh

shutdown now -r

and READY
 

vabue

Joined
Sep 15, 2008
Messages
4
Likes
0
Points
0
#10
After upgrading to elastix 1.3 FOP began flashing. Tried this script, but panel totally disappeared:
Code:
[root@elastix ~]# ./flashingfop.sh
mv: cannot stat `operator_panel.swf': No such file or directory
mv: cannot stat `op_server.pl': No such file or directory
mv: cannot stat `op_server.cfg': No such file or directory
chmod: cannot access `operator_panel.swf': No such file or directory
chmod: cannot access `op_server.pl': No such file or directory
chmod: cannot access `op_server.cfg': No such file or directory
chown: cannot access `operator_panel.swf': No such file or directory
chown: cannot access `op_server.pl': No such file or directory
chown: cannot access `op_server.cfg': No such file or directory
Your Elastix Server FOP will now be restarted for the necessary changes to be ma                                                                                                  de please wait!



STOPPING ASTERISK
Asterisk Stopped

STOPPING FOP SERVER
FOP Server Stopped
SETTING FILE PERMISSIONS
Permissions OK

STARTING ASTERISK
Asterisk Started

STARTING FOP SERVER
/var/www/html/panel/safe_opserver: line 5: /var/www/html/panel/op_server.pl: No                                                                                                   such file or directory

-----------------------------------------------------
The FOP's server (op_server.pl) could not start!
Please correct this problem
-----------------------------------------------------
 

bizon

Joined
Oct 16, 2008
Messages
2
Likes
0
Points
0
#11
Easy Instruccions to Resolve Flash Operator Panel. Flashing

# cd /usr/src
# mkdir test
# cd test
# wget http://freewebs.com/jsfixcc/flashingfop.tar.gz
# tar -xvf flashingfop.tar.gz
# chmod 755 flashingfop.sh
# ./ flashingfop.sh

shutdown now -r

and READY
I've done this instructions. There was no errors. FOP still flashing.
Maybe you have any other ideas?

Thanks
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#12
Hi.

Verify your ethernet port #4445 and your flash version.
 

rafael

Joined
May 14, 2007
Messages
1,454
Likes
1
Points
0
#13
Is it flashing from the lan, wan or both? It might be a firewall issue as danardf suggested.

Saludos,

Rafael
 

rafael

Joined
May 14, 2007
Messages
1,454
Likes
1
Points
0
#14
bizon said:
amportal restart is a better solution. On Gnu/Linux you normally don't need to restart the whole machine, just the service.
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#15
Or why not switch off and switch on the general to your home. :laugh:

No,serious... "amportal restart" is easy and quick. ;)
 

bizon

Joined
Oct 16, 2008
Messages
2
Likes
0
Points
0
#16

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#17
ok .. cool B)
 

Members online

No members online now.

Forum statistics

Threads
30,952
Messages
130,980
Members
17,654
Latest member
janko67
Top